Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to Ubuntu 13.04, from 12.04 (via 12.10) where I had been using Cinnamon 1.8.

Post-upgrade I have tried unsuccessfully to re-install Cinnamon.

I have tried:

  • From the 13.04 repo's but 'nothing' happens when I select Cinnamon from the logon menu (by 'nothing' I mean I get a blank screen and there are errors in syslog implying cinnamon isn't starting correctly)

  • From the developer's stable ppa : this is currently cinnamon 2.02 but the install fails with unmet dependencies:

    The following packages have unmet dependencies.
    
        cinnamon : Depends: libcogl-pango0 (>= 1.7.4) but it is not installable
                   Depends: libcogl9 (>= 1.9.6) but it is not installable
    
  • From the .deb packages at the developer's ppa specific for 13.04 but these produce many unmet dependencies (as expected I guess)

My thoughts are that the 13.04 repo's having 1.7.4 of Cinnamon in means that my 1.8 configuration is (somehow) making it fail to start. But I don't see why the installation from the developer's stable repo should fail with unmet dependencies.

Has anyone else met, and solved this?

(I've really tried to get on with Unity, but can't)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I have solved my own problem (not checked whether it works but cinnamon 2.0.2 is now installed edit Yes - it's working 'fine' on Ubuntu 13.04 : 'fine' = occasional locks probably nVidia linked)

The problem lay with a ppa from Quantel lying in my sources and hence confusing apt. I guess this was my fault although I don't recall adding the ppa ... I was on Quantel for about 2 hours.

So to resolve the issue I manually deleted the rogue ppa from my sources, and then tidied up using:

sudo apt-get install -f

sudo apt-get autoremove

sudo apt-get update

sudo apt-get upgrade

This got all installed packages to a happy state. I then verified the details for cinnamon:

sudo apt-cache policy cinnamon
cinnamon:
  Installed: (none)
  Candidate: 2.0.2-20131011040008-raring
  Version table:
     2.0.2-20131011040008-raring 0
        500 http://ppa.launchpad.net/gwendal-lebihan-dev/cinnamon-stable/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status
     1.7.4-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages

Installation of cinnamon still failed:

sudo apt-get install cinnamon
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 cinnamon : Depends: cinnamon-common (= 2.0.2-20131011040008-raring) but 2.0.2-20131011040209-quantal is to be installed
        Recommends: nemo but it is not going to be installed
        Recommends: cinnamon-screensaver but it is not going to be installed
        Recommends: gir1.2-cjsdbus-1.0 but it is not installable
        Recommends: cinnamon-bluetooth but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Which was due to my installation of cinnamon-common via the .deb (see my question).

Removed that:

sudo apt-get remove cinnamon-common

and then the straight-forward installation worked.

So my fault; the package is fine.

share|improve this answer
    
and did you have Cinnamon 2.0.2 working and the unity session did it working fine? –  Papachan Oct 20 '13 at 18:51
1  
Cinnamon 2.0.2 is working fine. I've not tried Unity since the installation though. Cinnamon lock-ups with nVidia bad in 3.04 and 3.10. Better in 3.10-updates. Not tried 3.13. (versions 3.xx refer to the nVidia proprietary packages. Nouveau drivers no good) –  Mike Oct 21 '13 at 19:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.