Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried looking thorugh your forums as well as many others, and I cant seem to find a solution to my problem.

I currently have a Ubuntu 12.04 VM installed on a hyper-V. I upgraded this system from a 10.04 system using the do-release-upgrade option. I went through the process of configuring the network settings through Network Manager, but I still cannot connect to the network. I have started and stopped the network manager service a number of times. i have also restarted the machine too. I tried editing the /etc/network/interfaces file and that did not work. I even tried sudo apt-get install --reinstall network-manager to see if that would help, and it has not. Also for some reason when I set the gateway, I am not able to ping my gateway address.

Is there something that I am missing? Is there something I am doing wrong? I cant revert to the previous version of Ubuntu because I forgot to take a snapshot before upgrading. I ran the command killall -9 NetworkManager and that will allow the Wired network to connect, but i still cannot get to the internet for some reason. I tries using steps from this forum below and still no luck.

http://ubuntuforums.org/showthread.php?t=1983054&page=4

Any help would be nice,

Thanks.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I was able to use the IRC room to help fix this. The issue is that I am in a Hyper-V environment. This box was using a legacy network adapter when it was on 10.04. Now that it is on 12.04 I removed the legacy adapter and added a new adapter, and it works now. thanks to the user hydruid

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.