Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a long hiatus, I finally decided to get Ubuntu Desktop back up and running. I recently purchased a second monitor, which I works, as it worked right out of the box with Windows. Ubuntu however doesn't seem to recognize the monitor at all; at no point am I getting a signal. Here are some things I've tried to fix the problem, but to no avail.

1: Update just about all packages and drivers and restart.

2: The display subsection in System Settings won't detect a second monitor (BBY seems to be my primary monitor, although it's an Insignia monitor, and isn't 32" either).

enter image description here

3: Installed nvidia-settings and nvidia-settings-updates.

4: Switched between all open source and proprietary NVIDIA video card drivers.

5: xrandr output (The second monitor is the VGA one):

DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 708mm x 398mm
   1920x1080      60.0*+
   1920x1080i     30.0  
   1280x1024      75.0     60.0  
   1280x720       60.0     60.0  
   1024x768       75.1     70.1     60.0  
   1440x480i      30.0  
   800x600        72.2     75.0     60.3     56.2  
   720x480        59.9  
   720x480i       59.9  
   640x480        72.8     75.0     60.0     59.9  
   720x400        70.1  
VGA-1 disconnected (normal left inverted right x axis y axis)

6: Unplugged and replugged the monitor.


7: output of lspic:

lancelafontaine@lancelafontaine-GT5634H:~$ lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation G86 [GeForce 8500 GT] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 01)


8: Attempted some of the solutions on this similar question. Stangely enough, It seems that I'm "forced" to use the open source driver for my video card, as seen below.

enter image description here

Any change applied only results in it immediately resetting itself to the open source option. Another note: I can't seem to access the "Nvidia X Server Settings" Opage as een in the other question. The additional drivers tab only yields the above result.

Seems as though Ubuntu isn't recognizing the monitor at all. Any one have any ideas? PS. thanks for keeping my newbiness in mind.

share|improve this question
Welcome to Ask Ubuntu. Please edit your question and add the output of lspic. –  MadMike Oct 15 '13 at 4:52
Thanks @MadMike, question edited. –  LanceLafontaine Oct 15 '13 at 19:58
Seems someone had a similar problem. Maybe it applies to your problem too? –  MadMike Oct 15 '13 at 20:09
@MadMike, thanks for the help, and the question has been edited once again to address it. –  LanceLafontaine Oct 15 '13 at 20:58
Try a different cable. This sounds like the computer can't physically see the monitor, and a common cause of that is a bad cable. –  Ian Santopietro Oct 15 '13 at 21:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.