Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

There is a glitch on the Ubuntu Software Center and whenever I open it an error appears and it keeps loading and never opens. Why does this happen? I have installed Ubuntu 13.04 on a disk and partitioned it. Please help me and ask for excess information if you need it. If you know of any duplicates please show me them!!

I get the following error in a terminal

SystemError: E:Type '<!DOCTYPE' is not known on line 1 in source list /etc/apt/sources.list.d/medibuntu.list

The /etc/apt/sources.list.d/medibuntu.list file contains a HTML document.

share|improve this question

marked as duplicate by dobey, Eric Carvalho, Kevin Bowen, psusi, Anwar Shah Oct 20 '13 at 15:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

What is the error saying? Please edit your question with this information. – minerz029 Oct 15 '13 at 0:42
It would be better if you provide the errors you are getting. Although you can try this command in terminal once: sudo dpkg-reconfigure software-center Reply what did you get.. – Saurav Kumar Oct 15 '13 at 1:20
SystemError: E:Type '<!DOCTYPE' is not known on line 1 in source list /etc/apt/sources.list.d/medibuntu.list I got this error doing both commands. It happened on the first one then I tried the second one and this happened too. – askubuntu7639 Oct 15 '13 at 1:30
Possible duplicate: How do I remove a broken software source? – TrailRider Oct 15 '13 at 1:37
If your /etc/apt/sources.list.d/medibuntu.list file contains a full HTML page, then this is really not the content it should have. This really does not happen by itself - you probably have put it there without knowing what you were doing. Try removing the offending file. sudo rm /etc/apt/sources.list.d/medibuntu.list and try again. – gertvdijk Oct 20 '13 at 16:16

The Medibuntu repository, which is referred to in your SystemError output, has now been shut down, the packages were either obsolete, unnecessary or moved to the official Ubuntu archive. Now that you can no longer pull packages down from the Medibuntu archive, you no longer need the medibuntu.list file in the /etc/apt/sources.list.d/ directory.

  1. Open the terminal and open the /etc/apt/sources.list file for editing in the nano editor:

    sudo nano '/etc/apt/sources.list'

    Delete any lines in sources.list that have medibuntu in them. Press the keyboard combination Ctrl+O and after that press Enter to save the sources.list file. Press the keyboard combination Ctrl+X to exit nano.

  2. Remove the medibuntu.list file from its location in the /etc/apt/sources.list.d/ directory. This command will create a backup directory and save a backup of the medibuntu.list file called medibuntu.list.bak in it:

    sudo mkdir backup && sudo mv '/etc/apt/sources.list.d/medibuntu.list' '/etc/apt/sources.list.d/backup/medibuntu.list.bak'
  3. Tell your system to update the latest list of software from each archive it knows about:

    sudo apt-get update
share|improve this answer
I typed in the command and there weren't any lines that said medibuntu in them. Can you give me any more help? – askubuntu7639 Oct 19 '13 at 0:54
Maybe your sources.list file is OK the way it is, so it doesn't need to be edited. In that case step 1. doesn't apply because it does nothing, so skip step 1. and just do step 2. and step 3. – karel Oct 19 '13 at 4:01
I tried step 2 and it said no such file exists. Then I got step three and I got the original error. – askubuntu7639 Oct 20 '13 at 16:02
Thanks!! I will too. – askubuntu7639 Oct 20 '13 at 16:05
I like this answer by Anwar Shah. Following the instructions in that answer will restore your system back to the default repositories. – karel Oct 20 '13 at 16:18

Try this command in a terminal

sudo sed 's/<!DOCTYPE//g' /etc/apt/sources.list.d/medibuntu.list

Then check if it works with this command:

sudo dpkg-reconfigure software-center

If it doesn't work, then edit your question with the output of this command:

cat /etc/apt/sources.list.d/medibuntu.list
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.