Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This might be a bug but it might just be an undocumented "feature". I'm asking because I want to know.

Edit: This is now also filed as a bug.

Edit: Here's a strace of gnome-panel.

Upgraded to Natty from Maverick today with the intention of keeping my panel-based Gnome2 setup. I've already asked if that's possible and it does appear that's the case.

My problem is on loading the panels, I get a ton of errors from very default applets like the Window list, Notification Area and Clock. Upon further investigation, I don't appear to be able to even add these types of applet. They're missing from the Add to Panel dialogue.

Is there a package I need to install to get these applets back?

Here's what I see on boot:

Argl

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Well this has been an adventure. I had seen this MintForum thread before but ignored it mainly because it was talking about bonobo (which is frankly a silly word) but also because the applet in discussion was the MintMenu.

I decided to go back there today and actually read it. plumm's post has given me a few clues and has actually got a few things working (after some modification). Here's what I'm doing. Until I've got everything back this post is a work in progress.

First you have to locate your bonobo-activation-config file:

# locate bonobo-activation-config
/etc/bonobo-activation/bonobo-activation-config.xml

Then we find where all the applets' bonobo-server-item-configuration files are:

# locate bonobo/server | grep GNOME
/usr/lib/bonobo/servers/GNOME_BrightnessApplet.server
/usr/lib/bonobo/servers/GNOME_DictionaryApplet.server
/usr/lib/bonobo/servers/GNOME_GtikApplet.server
/usr/lib/bonobo/servers/GNOME_InhibitApplet.server
/usr/lib/bonobo/servers/GNOME_Magnifier.server
/usr/lib/bonobo/servers/GNOME_Moniker_std.server
/usr/lib/bonobo/servers/GNOME_SeahorseApplet.server
/usr/lib/bonobo/servers/GNOME_TSClientApplet.server
/usr/local/lib/bonobo/servers/GNOME_ClockApplet_Factory.server
/usr/local/lib/bonobo/servers/GNOME_FishApplet_Factory.server
/usr/local/lib/bonobo/servers/GNOME_NotificationAreaApplet.server
/usr/local/lib/bonobo/servers/GNOME_Wncklet_Factory.server

Then we put the two together, creating new xml <items> in the bonobo-activation-config.xml. We only need the common path so there are only two things to carry. Here's my finished file:

<?xml version="1.0"?>

<oafconfig>

<searchpath>
    <item>/usr/lib/bonobo/servers</item>
    <item>/usr/local/lib/bonobo/servers</item>
</searchpath>

</oafconfig>

After a restart everything but GNOME_ClockApplet has loaded back up.

More on this when I've fixed it.

share|improve this answer
    
I had this exact same problem. Thank you for your partial fix. Did you figure out how to enable the Gnome Clock Applet? My Indicator applets are also nowhere to be found... –  Aibara Iduas May 7 '11 at 1:37

Well..there is a big issue here. Upgrading from maverick to natty is not going to be easy I must say! I have had the exact same issues as you are having . Try and follow these steps and see if it helps.

  1. Logout and login to the ubuntu classic session instead of unity.

  2. Open up synapic / software-centre/ terminal and remove all indicator applets

    sudo apt-get remove indicator-applets*
    
  3. then logout and log back in.

Now you will be able to see the gnome panels. Then you can add the existing applets If you cannot live without the ubuntu indicator applets try re-installing them. They have been causing errors for me in the gnome classic session. so i got rid of them.

Right now, i have a situation where even unity is creating a lot of issues for me. i am thinking of installing gnome 3 and check how it fares. if everything fails i will have to do a clean install.

share|improve this answer
    
No help I'm afraid. Removed all Indicator Applets (which unnervingly also removes ubuntu-desktop), restarted and same errors. I do get my panels, my on-panel launchers and Cardapio (albeit broken), but no other applets. –  Oli Apr 19 '11 at 13:22
    
ubuntu-desktop is a meta package which identifies ubuntu as a distribution. it does not affect your system. but, now that you have got your panels, you can add your applets one by one by right clicking on the top panel and selecting add to panel. if you can install docky and update the cardapio ppa and update the system. see what you get. the other idea that i can give you is create a test account and see how it behaves when you log into that account. –  Ubuntuser Apr 19 '11 at 13:33
    
ok. now i have my gnome2.32 classic desktop with cardapio, docky and the indicator applets all set. took me an hour to set it right. after removing all the indicator applets i restarted my system. then logging into the terminal using ctrl+alt+f1, i issued the follwoing command: sudo apt-get update && sudo apt-get install ubuntu-desktop. Remember, if you have any application from maverick which you think is conflicting with your new installation, just remove it. you can install it later on. –  Ubuntuser Apr 19 '11 at 14:11
    
I don't think removing indicator applets is a good idea. Removing ubuntu-desktop and then installing it again may help in pulling in missed recommended packages. –  Jeremy Bicha Apr 29 '11 at 3:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.