Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Vaio laptop Windows 7 has crashed and no longer sees the hard drive in BIOS (Seagate Momentus 5400.6), so although I have the 3 Windows restore (/repair?) discs they are unusable. I can load VAIO Rescue basic and Vaio Hard Disk Verify/Repair but they cannot see any partitions to copy from. I have tried running ubuntu from the DVD, get language selection but then blank screen, machine goes quiet and back to language selection.

I have removed the drive and am trying to recover from an external enclosure on a different machine (Vista if that's relevant). I have tried ubuntu direct from the disc - on this machine I get screen corruption then Error 8000 reading sector 824570 Invalid or corrupt kernel image EDD Error 8000 reading sector 47586.

I have installed ubuntu desktop on the Vista machine. This seems to operate fine, but I cannot get it to see the external drive.

Ideally I hope to solve this in a way which maintains Windows, MS Office and data (but not hopeful at the moment!).

lsblk 
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT 
sda 8:0 0 149.1G 0 disk 
├─sda1 8:1 0 1.5G 0 part 
├─sda2 8:2 0 74.5G 0 part /host 
└─sda3 8:3 0 73.1G 0 part 
sr0 11:0 1 1024M 0 rom 
loop0 7:0 0 6.6G 0 loop / 
geoff@ubuntu:~$ fdisk -l 
geoff@ubuntu:~$ 


Disk /dev/sda: 160.0 GB, 160041885696 bytes 
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors 
Units = sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disk identifier: 0x75dc365b 

Device    Boot  Start     End       Blocks   Id  System 
/dev/sda1       2048      3074047   1536000  27  Hidden NTFS WinRE 
/dev/sda2 *     3074048   159363071 78144512 7   HPFS/NTFS/exFAT 
/dev/sda3       159363072 312580095 76608512 7   HPFS/NTFS/exFAT 
geoff@ubuntu:~$

geoff@ubuntu:~$ dmesg | tail -n 50
[   21.432705] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   21.432708] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   21.432711] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   21.432714] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[   21.432716] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_P2P disabled
[   21.432720] iwlwifi 0000:01:00.0: Detected Intel(R) WiFi Link 5100 AGN, REV=0x54
[   21.432850] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
[   21.635481] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   22.310340] Console: switching to colour frame buffer device 160x50
[   22.315200] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   22.315202] i915 0000:00:02.0: registered panic notifier
[   22.327012] acpi device:06: registered as cooling_device2
[   22.327116] ACPI: Video Device [VGA] (multi-head: yes  rom: yes  post: no)
[   22.328771] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input8
[   22.329626] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[   22.329761] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[   22.329895] snd_hda_intel 0000:00:1b.0: irq 47 for MSI/MSI-X
[   22.336803] init: failsafe main process (794) killed by TERM signal
[   22.398169] input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
[   22.398498] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   26.058728] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[   26.160142] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[   26.160291] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   26.160843] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   26.163945] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
[   26.164543] iwlwifi 0000:01:00.0: Radio type=0x1-0x2-0x0
[   26.225261] type=1400 audit(1381768439.847:10): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=925 comm="apparmor_parser"
[   26.226037] type=1400 audit(1381768439.847:11): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=925 comm="apparmor_parser"
[   26.226480] type=1400 audit(1381768439.847:12): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=925 comm="apparmor_parser"
[   26.245324] type=1400 audit(1381768439.867:13): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=924 comm="apparmor_parser"
[   26.245873] type=1400 audit(1381768439.867:14): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper//chromium_browser" pid=924 comm="apparmor_parser"
[   26.341819] type=1400 audit(1381768439.963:15): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=928 comm="apparmor_parser"
[   26.342728] type=1400 audit(1381768439.963:16): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/telepathy-*" pid=928 comm="apparmor_parser"
[   26.350116] type=1400 audit(1381768439.971:17): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=929 comm="apparmor_parser"
[   26.351062] type=1400 audit(1381768439.971:18): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/cupsd" pid=929 comm="apparmor_parser"
[   26.368590] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
[   26.369026] iwlwifi 0000:01:00.0: Radio type=0x1-0x2-0x0
[   26.423071] type=1400 audit(1381768440.043:19): apparmor="STATUS" operation="profile_load" name="/usr/sbin/tcpdump" pid=931 comm="apparmor_parser"
[   26.507287] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   26.507799] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   34.850006] wlan0: authenticate with 58:98:35:c0:2b:79
[   34.852819] wlan0: send auth to 58:98:35:c0:2b:79 (try 1/3)
[   34.856557] wlan0: authenticated
[   34.860053] wlan0: associate with 58:98:35:c0:2b:79 (try 1/3)
[   34.863478] wlan0: RX AssocResp from 58:98:35:c0:2b:79 (capab=0x411 status=0 aid=4)
[   34.871093] wlan0: associated
[   34.871133] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   63.922405] audit_printk_skb: 24 callbacks suppressed
[   63.922414] type=1400 audit(1381768477.540:28): apparmor="DENIED" operation="open" parent=1 profile="/usr/lib/telepathy/mission-control-5" name="/usr/share/gvfs/remote-volume-monitors/" pid=1993 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[  897.526186] type=1400 audit(1381769311.145:29): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=805 comm="cupsd" pid=805 comm="cupsd" capability=36  capname="block_suspend"
geoff@ubuntu:~$ 
share|improve this question

closed as off-topic by Braiam, Eric Carvalho, psusi, qbi, Kevin Bowen Oct 15 '13 at 19:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Braiam, Eric Carvalho, psusi, qbi, Kevin Bowen
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Seem that you need some advanced tools to recover your data. You might be able to get more help in Super User since most of that software is not "Ubuntu specific". –  Braiam Oct 14 '13 at 14:21

1 Answer 1

Have you been using the same Ubuntu disk/thumbdrive/image to boot in these instances? Are you sure that it is not corrupt? A how to on checking the md5 sum is here: https://help.ubuntu.com/community/HowToMD5SUM

or you could simply re-download or image it and hope for the best.

however, now that you have a working copy of ubuntu installed..

Its good to do a full backup of the disk. The idea behind this is if the hard drive failure is mechanical, you are only accessing the drive once and utilizing whatever small amount of life is left in the mechanical parts, thereby preserving as much data as possible. Also, you now have a working backup image of your drive, should anything go wrong with the recovery. If the internal hard drive you have is large enough, dd is useful for this.

sudo dd if=/dev/sdX of=~/backup.dd bs=1M

where if= is the input file, the raw path to your device, and of= is the file you would like the data saved in. here I have also specified that the disk should be read in 1M chunks bs=1M, this will help improve performance.

If the internal drive you have is not large enough, it could get a little more tricky.

It seems like you may have a partition table corruption or error, which will be good because it means all of your data is intact. Its just that your computer doesnt know its there or how to read it.

A seemingly useful how to on NTFS partition recovery is found here using the ntfs-3g package (in the repositories) and fdisk to find the drive. I do not have an NTFS drive to try this on, but I found that ntfsprogs was no longer in the repositories but ntfs-3g provided the necessary tools as described in the tutorial.

Let me know if you would like any additional help.

share|improve this answer
    
Hi Paul, many thanks. I'm very new to linux so this is a bit of a stretch. Just to recap I have working ubuntu installed on a separate Vista machine, but it is not reading the crashed disc which I now have in an external enclosure attached to it. It seems a very good place to start by backing up the disc, but I don't see how I can back up the disc when running ubuntu on the Vista machine as it won't recognise it. Can you help me get started? Tks, I'll get on with your checksum suggestion now. –  user202605 Oct 14 '13 at 16:10
    
get back to me with the output of these commands from the vista machine from within ubuntu. Open a terminal, plug in the external, and sent back the output of these: lsblk and fdisk -l these will help us to determine just how unreadable this drive is. –  Paul Oct 14 '13 at 16:30
    
Apols don't know how to copy output from these cmds so that I can reply. fdisk-l returns blank. –  user202605 Oct 14 '13 at 16:39
    
if your in a terminal, highlight the text and press ctrl-shift-c, similarly to paste into a window ctrl-shift-v will work. this is to avoid the ctrl-c shortcut which kills the currently running command. also, make sure you include the space for fdisk -l edit-- also, sorry about that you will need to sudo fdisk -l in ubuntu to get anything useful –  Paul Oct 14 '13 at 16:40
    
geoff@ubuntu:~$ lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 149.1G 0 disk ├─sda1 8:1 0 1.5G 0 part ├─sda2 8:2 0 74.5G 0 part /host └─sda3 8:3 0 73.1G 0 part sr0 11:0 1 1024M 0 rom loop0 7:0 0 6.6G 0 loop / geoff@ubuntu:~$ fdisk -l geoff@ubuntu:~$ –  user202605 Oct 14 '13 at 16:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.