Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently installed Ubuntu on my machine and everything has been working fine, except I don't see the Dropbox indicator. I have installed and re-installed Dropbox multiple times and can confirm that it's running in the background (with ps -e | grep dropbox).

Does anyone know how to get it back?

share|improve this question
Please don't change your title to Solved – MadMike Oct 15 '13 at 9:40
I found this solution to work for me in 2016, 14.04:… – pokkie Mar 27 at 9:57
up vote 125 down vote accepted

Found a solution at the comment #7 from the Ubuntu bug:

  1. Install package sudo apt-get install libappindicator1

  2. Log out, and then log back in (or issue dropbox stop && dropbox start at the command line)

share|improve this answer
do you have any references? – minerz029 Oct 15 '13 at 9:57
Thanks for this answer, I was going crazy trying to find out how to display the "tray" icon. – Paul Gregoire Feb 25 '14 at 1:32
Weirdly, this worked for me even though step 1 told me that libappindicator1 was already installed. – TRiG Jun 10 '14 at 10:57
Weirdly, this did not work for me at all. – rmp251 Jun 10 '14 at 23:59
Bug in 14.04 so this answer is not working anymore. – Masi Jul 7 '15 at 8:15

If I recall correctly there is an unfixed bug in the dropbox package for 13.10. Cf. launchpad. This is at present a confirmed, but unassigned bug.

If this is not that bug, then read this question.

share|improve this answer
Answer in the above publication. – Sardinha Oct 26 '13 at 13:24

There is another issue that has popped up recently.
This is with regard to 14.04, being that,

Dropbox runs in the background but does not show the indicator panel icon even when appindicator1 is installed.

The only work around i found was to re-install Dropbox by getting the .deb file form the link: Download Dropbox

share|improve this answer
worker but needed a reboot – Pisu Nov 1 '14 at 10:47
This bug also in Debian 8. – Masi Jul 7 '15 at 8:13
I have this problem now , early 2016 and this solution is not working – makkasi Mar 8 at 14:15

Thanks to Denilson dropbox stop && dropbox start worked for me - but only until next reboot.

Solved it permanently by writing a short shell script (which i put into /opt directory):

sleep 60s
dropbox stop && dropbox start -i &

(mark as executable) and then click on the Ubuntu button on the left upper corner, type "startup" and there add an entry to call that start that shell script /opt/

share|improve this answer
Why would you restart dropbox every minute? That doesn't look like a good solution. (but, sure, it is a quick-and-dirty workaround) – Denilson Sá Aug 26 '14 at 17:23
This doesn't restart every 60s, running from opt as part of startup it runs only once per boot. – biggerScala Sep 3 '14 at 14:55
Nice solution. You can also combine this into one line sleep 60s && dropbox stop && dropbox start & and put directly into command field in Startup Applications – shea Jul 14 '15 at 15:58
I have this problem now I'm using SSD instead of hard drive - must be a timing issue as there is no problem when I use hard drive. I found I could not just modify command of dropbox Startup Application because next time dropbox starts, it just overwrites it. Also I had to add a sleep between the stop and start as the stop returns well before it actually stops. I created /usr/local/bin/dropbox_delayed which does sleep 60 && dropbox stop && sleep 60 && exec dropbox startand created new Startup Application DropboxDelayed which has command dropbox_delayed. Works fine for me. – Chris Good Aug 19 '15 at 6:40
Also, I could not put multiple commands in Startup Application command i.e. sleep 60 && dropbox stop etc. Does not work (Ubuntu 12.04). – Chris Good Aug 19 '15 at 6:43

As of ubuntu 14.04 do this to put dropbox icon on menu bar :

sudo apt-get install nautilus-dropbox

You can start Dropbox from your applications menu.

share|improve this answer
well, I can start it from the menu, but the icon stil does not show up. I guess that is what I get when using beta versions of 14.10 ... – oligofren Oct 5 '14 at 21:02
It not solves the problem – deFreitas May 11 at 2:51

I'm on 14.04 with Gnome 3. None of the above solutions did work for me.

A solution that worked finally was to install a gnome extension 'topicons'

share|improve this answer

protected by Community Oct 30 '13 at 17:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.