Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is becoming increasingly annoying and borderline despairing:

I use sshfs to mount directories from remote servers. I work in a laptop with a docking station so I'm usually connected through ethernet. Many times I need to grab my laptop and go work in another location using the company's WIFI connection.
If i forget to "fusermount -u" all the different mounts, I need to restart the computer or at least logout login, which is very annoying and unproductive.

When i say everything is messe up i mean:

  • My console stops working if i do something as simple as 'ls'
  • I can't unmount either through the console or the File Browser
  • Consequently, i can't mount it again, therefore i can't work

Does anyone relate to this problem? and know of a good solution?

Thank you

share|improve this question
    
This answer might be interesting. –  MadMike Oct 14 '13 at 12:02
    
i've tried it and it works!!! want to add it as an answer, so i can accept it as the right one? thanks –  André Alçada Padez Oct 14 '13 at 12:20

1 Answer 1

up vote 1 down vote accepted

How to setup sshfs with the "reconnect" option

Pulled from this answer.

You can run sshfs with the "reconnect" option. We use sshfs with PAM/automount to share server files for each workstation in our network. We use -o reconnect as parameter for sshfs, mostly because our users suspended their computers and on wake sshfs would not reconnect (or respond, or anything).

For example:

sshfs [email protected]:/home/mvaldez/REMOTE /home/mvaldez/RemoteDocs -o reconnect,idmap=user,password_stdin,dev,suid

Just a note, if the remote computer is really down, sshfs may become unresponsive for a long time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.