Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a Macbook. The folders appear to be locked with a lock icon( like Music, Video etc.). The folders like documents seem to be working fine. I can't do anything on my mac as it is not booting but i need to take the data out of it. Can I do it from a Ubuntu Live USB stick?

share|improve this question
make sure they are not encrypted by the mac os. – sazary Apr 19 '11 at 8:05
up vote 1 down vote accepted

As Slipstream has answered you can use root privileges to access and copy the contents through terminal. All you have to do is boot from a Ubuntu live USB/CD and use following commands:

  1. Open terminal via Applications > Accessories > Terminal; use sudo su to gain root user privileges and ls /media/MacOSDrive to list the contents. After MacOSDrive you can append /Documents/ or any such directory name to list out their contents.
  2. Once you are sure about the contents you need to copy use sudo cp <source drive, say /media/MacOSDrive/Documents> -av <destination drive, say /media/an_external_drive>, where a stands for all contents and v for verbose mode, which lists out what is being copied file by file.

Hope it helps.

share|improve this answer
This worked perfect. Managed to copy everything without a problem. Thanks for the help. – Rajat Apr 21 '11 at 16:41

Ubuntu can access HFS+ which Mac uses. If you run:

gksudo nautilus

(I assume Gnome desktop), then you may get write access to the partition(s) and can then retrieve your data. I suggest you make a copy and put it somewhere safe.

share|improve this answer

You might not have the right permissions to access them. You can still get at them using sudo though.

So say if you wanted to get into /media/MacOSDrive/Music/ or something then type:

cd /media/MacOSDrive/

And you should see the folders listed that you can't get into. Try getting into the music directory:

cd Music

And it will say no in some way, then use sudo,

sudo cd Music

Then you should be able to get in, use ls to see the files in there.

share|improve this answer

I believe this thread will solve the problem for you. Just follow the steps listed in comment three. This is the same solution I used when I had this problem on my macbook. It's a more permanent solution then going through the terminal as root all the time.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.