Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Ubuntu Natty beta 2 32bit with WUBI, but whenever I try to install it always tries to download 64 bit version.

How do I ensure that it downloads 32 bit instead of 64 bit?

share|improve this question
@bcbc I don't know if having an accepted answer really matters. The other question has an upvoted answer that says basicly the same thing you said in your answer to this question. But I agree with you, the other question should be duped to this one, since it's older, has more upvotes and better answers. – Eric Carvalho Jun 10 '13 at 15:59
up vote 6 down vote accepted

Wubi chooses 64-bit automatically if you have a 64-bit CPU. You can override it with the command line option --32bit. This option is required even if you download the 32-bit desktop CD ISO yourself and place it in the same folder as wubi.exe before running.

See the Wubi guide for more info.

When you are installing a beta version of Ubuntu, the CD images and therefore the checksums change frequently, so even if you have the 32 bit ISO it may still reject it. If you are running from a CD, disconnect from the internet or use --skipmd5check to bypass this check (in this case you should make sure you have previously run the md5 check yourself). This is not recommended for non-beta installs, in which case you should let Wubi run the MD5 check.

share|improve this answer

Put the 32bit ISO in the same directory as Wubi.exe. You can also install magicdisk / deamontools and mount the ISO (Windows is primitive and cannot do this alone), and run the installer there.

I suggest you resize your partitions and make free space for Ubuntu to install a real Ubuntu. This will run better as it will not be affected by NTFS fragmenting the wubi disk file but is also far easier to troubleshoot as you can boot to live CD and access the partitions with ease.

share|improve this answer
Doesn't work, it still tries to download a 64bit version. – Madhava Apr 19 '11 at 11:37

It worked after disabling internet connection and then having ISO file and wubi file in the same folder.

share|improve this answer
This sounds like a bug, you should possibly write a bug report so it can be addressed prior to release – Thomas Ward Apr 19 '11 at 14:54
@August This post is by the author. It's quite appropriate for the OP to answer their own question in this way. Furthermore, if someone else had answered with this information (saying to turn off the Internet connection and install with the ISO image and the Wubi installer executable in the same folder), this would still be a perfectly good answer. (In contrast, this is not a comment--if this had been posted as a comment, I would comment asking that it be re-posted as an answer.) – Eliah Kagan Sep 6 '12 at 13:35

You can use the following method:


  2. MOUNT 32BIT ISO IN WINDOWS VIRTUAL DRIVE (no additional software is required in the case of windows 8)
  5. CHANGE DIRECTORY TO E:\WUBI-INSTALLER (i.e. the location in your PC where the installer is copied)

      wubi.exe --force-wubi --32bit

(with this step, the installer will automatically detect and use the mounted ISO image)


IMPORTANT NOTES:- USE THE wubi.exe FROM THE SAME ISO PACKAGE WHICH YOU'RE USING FOR THE INSTALLATION. Using this method, you can install the 32 bit version of ubuntu inside windows using the downloaded ISO image.

have a nice day


share|improve this answer

This is a bug. Actually I also tried to download and I downloaded 32 bit and it becomes 64 bit amd. But I am sure that my computer has 32 bit. It drives me crazy. So, finally, I saw the answer and will try to disconnect from internet as well.

share|improve this answer
It's not a bug. You may be running 32bit windows, but it doesn't mean your computer has a 32bit architecture. Post your chip spec or google it online and you'll see it is right. – bcbc Aug 7 '11 at 0:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.