Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just downloaded ubuntu 13.04, and am attempting to run it from vmware player 6. I have previously successfully run ubuntu 10.10 on vmware player 6.

My laptop OS is vista.

If I select create a new virtual machine, and select the iso-file, there is an error which says:

# Could not detect which operating system is in this disc image.  
# You will need to specify which operating system will be installed", but it is added to the menu when I select "Linux" as the OS type.

Now this what happens when I try to launch 13.04 from the vmware player:

I see ubuntu 13.04 listed on the menu to play in vmware. When I play it, a window appears which says:

# Network boot from AMD Am79C970A
# Copyright (C) 2003-2008 VMware, Inc.
# Copyright (C) 1997-2008 Intel Corporation

# CLIENT MAC ADDR: 00 0C 29 4C 24 2E  GUID: 564DB112-F848-1088-3CB7-956F2C4C242E
# PXE-E53: No boot filename received
# PXE-M0F: Exiting Intel PXE ROM.

# Operating System Not Found

And there is a message bar at the bottom of vmplayer which says:

# Ubuntu is not installed on this virtual machine.  Insert the installer disc and click "Restart VM""

Is this only a problem with 13.04? (It takes me a long time to download.) I would really appreciate if someone please help me to get it running!

share|improve this question
    
I'm not sure about this, but if I'm correct, it's because the main boot option is a Network Drive. I'm not sure how to change this in VMware Player, but try to check in the Virtual Machine settings, the main boot options, and select your Ubuntu iso. –  Christian Oct 13 '13 at 21:18
    
I'm sorry I checked for this and didn't find anything. When you use the "Create New Virtual Machine Wizzard" the first option is to select between "Installer Disk" or "Installer disk image file (iso)", I have selected the latter, and browsed to and selected the corresponding "ubuntu-13.04-desktop-i386.iso" file. –  Stephen Kramer Oct 13 '13 at 21:43
add comment

1 Answer

up vote 0 down vote accepted

I just installed Ubuntu 13.04 (64 bit) on VMWare Player 6. When creating the virtual machine and selecting the ISO file, VMWare automatically detected the Ubuntu operating system and suggested using Easy Install. I'm not sure why this did not work for you.

I am guessing that you created a new virtual machine and called it 'Ubuntu 13.04', even if you did not yet install Ubuntu 13.04. To install Ubuntu on this machine, you will need to mount the Ubuntu ISO file into its virtual CD player.

One way to do this is to select your virtual machine and press 'Edit virtual machine settings'. Then, select 'CD/DVD (sata)' from the menu on the left. Select 'Use ISO file' on the right, browse and select the ISO file that you downloaded. You should now boot from the Ubuntu live disk from where you can install the operating system.

If this still does not work, your downloaded ISO file could be corrupt. This would explain why VMWare did not recognise the ISO file. An indication could simply be the file size of the ISO file, which should be 785MB for the 64 bit version and approximately the same for the 32 bit version. If your file is significantly smaller, your download was probably interrupted.

share|improve this answer
    
Thank you very much for the suggestions. I did as you said, however the same error occurs. The iso zip file file size is 663,232kb. I also thought it could be the location of the iso file and the working directory location, however I matched them to be similar to the original ubuntu10.10 setup that works. I am using a partitioned drive for all my linux OS files. I don't know if it's a problem but I did extract the files using winzip at one point, not being sure what to do with it intitially. I'll re-download (for another hour). Thanks! –  Stephen Kramer Oct 13 '13 at 22:11
    
That file is indeed too small, and cannot be a valid Ubuntu ISO. I am not sure what file you downloaded. You should have downloaded an ISO file, not a ZIP file. It is possible to extract ISO files using WinZip, but you should not do this. Do you still have the link to the file you downloaded? You will probably want to download Ubuntu from the Ubuntu website (ubuntu.com/download/desktop). Also, don't forget to accept this answer after your problem is solved :). –  Semafoor Oct 13 '13 at 22:17
    
I forgot to mention, I had downloaded it from within my original ubuntu10.10 VM, and copied the file to vista. I'll re-download from vista (for another hour). Thanks! –  Stephen Kramer Oct 13 '13 at 22:19
    
The filename I used is: ubuntu-13.04-desktop-i386.iso from the link you show, for 32 bit. However the filetype And I see, it's supposed to be 794MB so I was missing a few as you stated. –  Stephen Kramer Oct 13 '13 at 22:21
    
That can't be right, that would be an Ubuntu 10.10 ISO :). Seeing as you got a 32-bit version of 10.10 going, it is probably safest to download the 32-bit version of 13.04 as well. Download the ISO from the Ubuntu website, and your Ubuntu VM will be up and running in an hour. –  Semafoor Oct 13 '13 at 22:25
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.