Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 13.10 has a different menu for Text Entry.

I'm using Caps Lock for swiching language input. After upgrade from 13.04 I'm not able to switch languages with Caps Lock.

Looks like upgrade broke previous settings (annoying). How do you make Caps Lock switch languages again using UI Settings? setxkbmap magic is not suitable.

share|improve this question

closed as off-topic by Seth, guntbert, Braiam, Florian Diesch, psusi Oct 22 '13 at 2:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Seth, Braiam, psusi
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
It might be a bug. Take a look at bugs.launchpad.net/ubuntu/+source/indicator-keyboard/+bug/… –  Mitch Oct 14 '13 at 18:47
1  
possible duplicate of How to use alt+shift combo to switch keyboard layout in 13.10 –  Georgy Ivanov Oct 18 '13 at 12:23
    
It is a duplicate, provided OP adds CapsLock to title. –  skfd Oct 22 '13 at 14:46
1  
Given that this is helpful for users who want an answer rather than reading through > 400 comments of the devs of 10 packages who were negligent enough to essentially break ubuntu's usability for users internationally and release packages with known bugs, I don't think this is off topic. I think it's a high quality question. –  Darioush Oct 24 '13 at 5:41

1 Answer 1

up vote 12 down vote accepted

In Ubuntu 13.04 this was simple: go to System SettingKeyboard LayoutOptionsKey(s) to change layout and tick Caps Lock:

Keyboard Layout Options

But in Ubuntu 13.10, Keyboard Layout, now called Text Entry, has undergone many changes, and for the moment, until a a correct fix for this bug will be released, is a little bit more complicated to switch input language with Caps Lock.

After I added the following PPA to my list of sources using the following command:

sudo add-apt-repository ppa:attente/1218322

and after I upgraded my system using:

sudo apt-get update
sudo apt-get upgrade

I was able to change the default Super+Space keyboard shortcut to Caps Lock:

Text Entry

Many thanks to William Hua (attente) for his Input source switching PPA. As he said, he will keep the PPA up-to-date until a correct fix for this bug is released.

share|improve this answer
    
Any chances for stateless layout switching? I.e. first layout on caps, second on shift+caps. This was easy as pie with the dialog you've shown, but not in Saucy anymore. WTF? –  ulidtko Nov 2 '13 at 22:27
    
It's fixed now. Turns out it was some kind of spec miss or just a bug. –  skfd Dec 6 '13 at 15:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.