Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've the latest stable versions of firefox and chrome. But when I run bodybrowser I get the following error:

Google Body uses WebGL, a new standard for 3D on the Web. Your browser supports WebGL, but WebGL is not initializing properly

How can I get this to work?

share|improve this question
    
If possible, please consider closing some of your other open questions by selecting the best answer (if they have one). Consider which answers have been useful and need an upvote. We need users to maintain their questions so that the site can be an effective tool for the next person with your problems. For more details on best practices consider reading the FAQ on asking questions. –  hexafraction Jun 7 '12 at 22:48
add comment

3 Answers

In order to check whether your browser supports WebGL, visit http://get.webgl.org/

Linux and WebGL have teething problems, and in many cases it just does not work. Whenever there is a support question, you need to provide

  1. what graphics card you have
  2. which driver you are using (mostly if they are the free/closed ones for ATI or NVidia). Newer Intel graphics drivers may be supported, older are quite unlikely.

In most cases you can force your browser to use WebGL; follow the link that it given when you visit http://get.webgl.org/

share|improve this answer
    
@user4124- I tried this - webgl.disabled false webgl.force-enabled true webgl.force_osmesa false webgl.prefer-native-gl false webgl.shader_validator true webgl.verbose true -- didnt work then I tried this - To Enable WebGL: 1. Type about:config in your browser 2. Mouse Right-Click 3. Choose New - Boolean 4. Type in new appeared window: webgl.enabled_for_all_sites Enable = True 5. Restart Firefox..... didnt work either!!!! –  avi Apr 18 '11 at 22:21
add comment

In Chromium (or Google Chrome) you can type about:flags and search (ctrl + f) to WebGL. Activate it then restart your browser.

share|improve this answer
add comment

It is possible for the WebGL support to become broken by a misbehaving WebGL app. When this happens, WebGL apps will not be able to run.

This can be fixed by restarting all instances of your browser.

A relatively non-destructive way of doing this in Chromium (so you don't lose open pages) is to go to about:flags and disable WebGL (by selecting 'Enable'), then 'Relaunch Now', then re-enable WebGL and relaunch again.

There's probably a more straightforward way, but I am not aware of it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.