Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I use Qwerty hotkeys with the Dvorak keyboard layout? For example I want C to map to J, but Ctrl + C to remain as Ctrl + C.

The dvorak-qwerty program is supposed to do this, but does not work for me.

Desired behaviour seems to occur in the terminal and with foreign language layouts.

share|improve this question
    
Any particular version of Ubuntu? –  Rinzwind May 24 '11 at 18:15
    
@Rinzwind: I'm using 10.10, but this layout would be worth the hassle of updating if need be. –  Josh May 24 '11 at 18:37

2 Answers 2

Please see this bug and the long and heated discussion around it: https://bugzilla.gnome.org/show_bug.cgi?id=162726

The behaviour you want was actually the default behaviour before and was considered a bug by people using the Dvorak layout...

PS: That it works in gnome-terminal is considered a bug...

share|improve this answer

Reported on Launchpad as bug 794510. Reported on GNOME Bugzilla as bug 652104.

No option to use Qwerty hotkeys in alternative Latin keyboard layouts

Some users prefer to use an alternative Latin layout such as Dvorak to increase their typing speed. Many of these users prefer to use the original Qwerty keyboard shortcuts which are conveniently positioned (e.g. Ctrl: C-Copy, V-Paste, S-Save). An option should be provided to use Qwerty hotkeys with alternative layouts.

Qwerty hotkeys are already used in the terminal and in non-latin keyboard layouts. Qwerty hotkeys were used in all keyboard layouts before bug 162726 was fixed.

GNOME Bugzilla bug 162726 argues the converse; comment directing to new bug added.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.