Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently I use the character palette applet in gnome panel to put special characters into text.

This is okay, but I have to stop typing, select the character I want from the applet and then copy and paste.

Is there a way to simply type special characters with different key combinations? If so, how do I do it?

share|improve this question
    
Run gucharmap. Applications -> Accessories -> Character map. – Anonymous Nov 10 '11 at 21:54
    
Do for the compose key in right alt gsettings set org.gnome.desktop.input-sources xkb-options "['compose:ralt']". Source askubuntu.com/a/784005/25388 – Masi Jun 7 at 16:42
up vote 60 down vote accepted

Often this is easier with the compose key. With that configured you use key combos to get the special characters. For instance:

  • For ë you press Compose+", e.
  • For you press Compose+~, e.
  • For ô you press Compose+^, o.
  • For á you press Compose+', a.
  • For à you press Compose+`, a.
  • For you press Compose+=, e.
  • For £ you press Compose+-, l.

Note that you do not have to hold down the compose key; just press each key in order.

To set the compose key go to System -> Preferences -> Keyboard, then Layouts -> Options. Open up Compose Key Position and choose a key. I use Right-Alt.

share|improve this answer
12  
Spot on, except for one thing - you don't need to hold down the compose key at all. Just hit the compose key, `, then a, and voilà! – Jeremy Kerr Jul 29 '10 at 13:16
    
Yep. You're right. Habit made me think that it was actually required. – Dave Jennings Jul 29 '10 at 13:18
    
+1 for allowing me to get rid of the special characters panel applet – jfoucher Aug 1 '10 at 9:36
2  
I recommend assigning the Compose key to Caps Lock, which I am pretty sure only comes standard on keyboards to annoy people. – tyjkenn Aug 16 '12 at 1:15
1  
á <-- it worked! – Dave Jun 26 '15 at 4:09

If you know the unicode value of the character you'd like to type, hit CTRL+SHIFT+u and then type the unicode.

Example:

CTRL+SHIFT+u 0 3 b b ENTER

results in λ.

share|improve this answer
1  
I seriously didn't know this was possible. Many thanks. For anyone wondering where to find the unicode umm... codes, unicode.org/charts/index.html is the place to go. – taneli Jul 25 '12 at 20:02
2  
Seriously, only people on Windows do that. – rds Sep 19 '13 at 20:01
    
do you know how to do this in wps office? – Marcel Oct 19 '15 at 21:29
    
@taneli also you can use other way. click the Keyboard Layout Icon on the top bar, then click the Character Map link in the dropdown menu. – Interesting Knox Mar 20 at 13:58

The easiest way I've found to do this is to set your keyboard layout to USA International (AltGr dead keys), then use Right-Alt+whatever to get the character you want. Obviously this does not work for all international/special characters, so if you need one that's not available through this method, use one of the other methods listed here.

Wikipedia gives us a handy diagram of the available characters and the keys they are mapped to.

share|improve this answer
    
It's also relatively easy to edit a keyboard layout file and tailor it to one's needs: — – «» “” … – ΤΖΩΤΖΙΟΥ Sep 4 '10 at 0:32
    
Most local keyboard layouts (e.g. Belgian, French, etc.) also support AltGr, but the selection and location of special characters will be different. The exact layout can be seen on a similar diagram from inside the keyboard configuration. – JanC Jun 9 '11 at 13:23

Here is an answer close to 1st answer, with a little alternative: I do not need to use compose because I set my keyboard to English US international instead of English US or English UK.

So I use the following combo:
" then e for ë
' then e for é
` then e for è
` then a for à
~ then n for ñ

and
" then spaceBar for "
' then spaceBar for '
` then spaceBar for `
~ then spaceBar for ~
Alt Gr plus 5 for

share|improve this answer
    
Is this still the case in Ubuntu 15.10? I don't get this working anymore. Setting either 'English (US, international, with dead keys)' or 'English (international, dead keys via AltGr)' doesn't work. – Lode Jan 28 at 21:10
1  
I've found that setting the 'English (US, international, with dead keys)' actually works if set via lxkeymap (sudo apt-get install lxkeymap). Even more interesting, it only needs to be set once, as if some extra config is changed to make it work. (Dutch source: sites.google.com/site/computertip/toetsenbord) – Lode Jan 28 at 21:28
    
@Lode sorry I ve not install 15.10 yet. – Boris Mar 24 at 19:23

You can use Ctrl + U and type Unicode number of the sign you want to type. So for ē you have to type Ctrl + U + 113.

share|improve this answer

Note for dummies like myself. It took me a while...

  1. Press Cont & Shift & u together
  2. Let go of all three keys
  3. input code (for example: 00e1 for á)
  4. Enter
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.