Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My PC has two audio 3.5mm audio outputs:

  • back - used for speaker system
  • front - used for headset

This is my audio controller:

id:  multimedia description:    Audio
device product:     N10/ICH 7 Family High
Definition Audio Controller vendor:
    Intel Corporation physical id:   1b
bus info:    pci@0000:00:1b.0 version:
    01 width:   64 bits clock:  33MHz
capabilities:   pm msi pciexpress
bus_master cap_list configuration:  
driver  =   HDA Intel latency   =   0
resources:   irq    :   44
memory  :   fea78000-fea7bfff

The problem is that up to ubuntu 10.10 I could right click the speaker symbol in notification area and switch between:

  • analog headphones (sound only over headphones)
  • analog output (sound on both headphones and speaker system)

This was very convinient because I didnt always have to shut down the speaker system if I only wanted to use headphones. Any idea what caused this change and how to fix it?

share|improve this question

3 Answers 3

This is likely a PulseAudio issue.

Install the package padevchooser and then use it to configure your sound card.

share|improve this answer

I have a similar problem.

I have a monitor with speakers attached to the back jack connector of the computer and my headphones to the front jack connector.

In Ubuntu 10.10 I could change my sound preferences for front and back so I could choose only to have sound in the headphones so I had an option not to disturb other people.

But in Ubuntu 11.04 in the output tab whether I choose Analog Headphones, Analog output or Analog Speakers I get the sound to both speakers and headphones all the times.

I have tried to use padevchooser as well and tried to change the Sound Preferences there as well without any result.

I hope someone has the answer or can help somehow.

My lspci -vv of the audio device:

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06) Subsystem: Intel Corporation Device 0038 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+ Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- SERR- Kernel driver in use: HDA Intel Kernel modules: snd-hda-intel

share|improve this answer
    
i tried to, there are a lot of options in padevchooser but i had no luck as well. –  Joe Hopfgartner May 16 '11 at 17:21

Click the audio menu in the top right panel. Select Sound Preferences.

Switch to the Output tab. Choose the output you want to control in the Connector dropdown.

share|improve this answer
    
this is exactly what i used to do but what doesnt work any more. –  Joe Hopfgartner Apr 19 '11 at 11:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.