Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As we have to have active compiz with Unity, I can't change the color, size, etc. of the cursor.

Is there any way for do it?

share|improve this question

3 Answers 3

up vote 8 down vote accepted

This is a known bug in compiz see https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/141500.

A found a workaround that works great for me on the bug page.

  1. Create a file
  2. Mark it as executable (Right Click > Properties > Permissions > Allow executing file as program)
  3. Open in gedit and paste the following

    #!/bin/bash
    
    mkdir -p $HOME/.icons/default
    CURSOR_THEME=$(gconftool -g /desktop/gnome/peripherals/mouse/cursor_theme)
    echo "[Icon Theme]
    Inherits = $CURSOR_THEME" > $HOME/.icons/default/index.theme
    echo "Compiz will be restarted to enable this. Please stand by."
    compiz --replace &
    

Then Just run that file every time you change your mouse theme.

share|improve this answer
    
This works great, with the only side-effect being that I have to restart my user session for compiz/unity to recover properly. –  Chris Kerrigan May 16 '11 at 2:29

Edit /usr/share/icons/default/index.theme to include the name of the new theme and restart compiz. You will also need to choose the icon theme in gnome-appearance-properties for each user, in order to get certain programs like firefox and gdm to behave.

share|improve this answer

The way I got round this was to remove the default cursor theme.

Copy & paste this command into Terminal

sudo apt-get remove dmz-cursor-theme

Now the new cursor theme you want will be applied.

share|improve this answer
    
The black cursos was remove. But then it does nothing. –  Kern Goldstein Apr 18 '11 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.