Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I had windows 7 installed, and I set my PC clock to a specific time. It worked fine but then i also installed Kubuntu (now its a dual boot). Whenever I run Kubuntu my clock changes time by -4 hours and when I again run Windows its time too has changed. So every time i set my clock in windows, Kubuntu changes it by -4hrs and this also effects my windows clock any help?

share|improve this question

marked as duplicate by Eric Carvalho, karel, belacqua, BuZZ-dEE, nux May 19 at 22:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
FYI, it's not just Kubuntu ,booting into any Linux OS and then into Windows changes Windows clock. –  Uri Herrera Jun 7 '11 at 20:09
add comment

4 Answers 4

By default Ubuntu assumes that the BIOS clock is set to UTC and adds or subtracts the appropriate amount of hours from it to get your localised system time. By contrast, Windows sets its system time directly to the time shown by the BIOS clock on boot. Thus, Windows assumes BIOS clock to be in your local time.

If Ubuntu keeps showing the correct time automatically and Windows keeps reverting to UTC, your Ubuntu installation is probably set to automatically get the correct time from a time server on boot.

The easiest way to fix the problem is to edit /etc/default/rcS and change the line that says UTC=yes to UTC=no. You can open the file for editing by opening a terminal and entering:

sudo nano /etc/default/rcS

Then simply find the appropriate line, replace yes with no, and save. If you prefer a graphical text editor try using gedit (Ubuntu) or kate (Kubuntu) instead of nano in the above command.

share|improve this answer
add comment

Have you tried changing the Time Settings to update manually?

enter image description here

share|improve this answer
add comment

Remember during installation when it asked if your clock was set to UTC and said "If you're not sure answer this question no"? You answered incorrectly.

share|improve this answer
add comment

Windows uses GMT to set it's clock time , while Linux uses UTC (the BIOS uses UTC too hence the BIOS and Linux clock's are the same).

That's why booting into Linux and then into Windows changes it's clock by ~4 hours.

share|improve this answer
add comment