Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Intel Centrino N 2230 WiFi card and I tried to download iwlwifi tar from Ubuntu wireless drivers and then I copied its .ucode to firmware folder and then I ran modprobe -r lawgn and modprobe lawgn. It didn't run, even after restart. Then I updated the compat-drivers but still didn't work.

I tried rfkill unblock all, checked the button, etc. but it didn't show up in airmon-ng and iwconfig.

Can anyone kindly help?

This is the output of mine:

lshw -C network 

*-network               
   description: Ethernet interface
   product: RTL8111/8168B PCI Express Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0.2
   bus info: pci@0000:07:00.2
   logical name: eth0
   version: 0a
   serial: 28:92:4a:1d:af:a1
   size: 100MB/s
   capacity: 1GB/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.3 latency=0 link=yes multicast=yes port=MII speed=100MB/s
   resources: irq:41 ioport:2000(size=256) memory:61404000-61404fff memory:61400000-61403fff
*-network UNCLAIMED
   description: Network controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:08:00.0
   version: c4
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: latency=0
   resources: memory:61500000-61501fff

iwconfig  
lo        no wireless extensions.
eth0      no wireless extensions.

airmon-ng   
Interface   Chipset     Driver

lsb_release -a; uname -a  
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 10.04.2 LTS
Release:    10.04
Codename:   lucid
Linux bt 2.6.38 #1 SMP Thu Mar 17 20:52:18 EDT 2011 i686 GNU/Linux
share|improve this question
    
That's odd; even I have a Centrino Wireless-N 2230 card and it works out of the box with no problems. Run "lshw -C network" and "iwconfig" and give the output in the question (edit the question). –  Ramchandra Apte Oct 13 '13 at 8:17
    
Can you also include the output of lsb_release -a; uname -a –  Warren Hill Oct 13 '13 at 8:42
    
Welcome to Ask Ubuntu! Please use the "contact us" link at the bottom of this page to ask for your unregistered account and your new registered account to be merged. Thanks. –  guntbert Oct 15 '13 at 6:35

1 Answer 1

You have a common conundrum; a newer wireless device and an older Ubuntu version. The PCI.ID for your device isn't included in the iwlagn version in 10.04. I suggest you upgrade to Ubuntu 12.04.3 LTS where your wireless will work perfectly with no further steps.

If you are committed to Ubuntu 10.04, please get a wired ethernet connection, open a terminal and do:

sudo apt-get install linux-backports-modules-wireless-3.3-lucid-generic

Detach the ethernet. After a reboot, your wireless should be working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.