Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Just upgraded from 13.04 to 13.10.

Everything went fine but I don't see the time in the top right corner of the 'top bar' anymore. I tried to right click on it so I could get some options but nothings shows.

I'm sure it's obvious but I don't see it.

share|improve this question

marked as duplicate by Oli May 30 at 12:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
I think you have hit a bug. –  Braiam Oct 12 '13 at 19:16
1  
I think I did... –  Paté Oct 12 '13 at 21:02
2  
Did you ever file a bug report? I'm now experiencing this myself. –  Seth Oct 14 '13 at 20:49
5  
This is not "problems with the development version of Ubuntu" - I upgraded to the official release of 13.10 experienced the same problem. Maybe it's a bug though. –  Insperatus Oct 22 '13 at 17:12

3 Answers 3

up vote 69 down vote accepted

Already solved here and here.
From the terminal:

sudo apt-get install indicator-datetime
sudo dpkg-reconfigure --frontend noninteractive tzdata
sudo killall unity-panel-service

Then logout & login from the graphic session.
If the clock is still hidden/grayed out:

Time&Date panel --> Clock --> Show a clock in the menu bar

If it still doesn't work report a bug on Launchpad.
*edited to solve a bigger slice of problems.

share|improve this answer
    
It was already installed, purged and reinstalled but the clock panel under data/time is still greyd out. –  Paté Oct 12 '13 at 18:59
2  
13.10 here, bingo. It works. –  David Cesarino Oct 20 '13 at 5:27
4  
Still doesn't work for me on 13.10 - the panel you show above is greyed out for me. –  Ziggy Oct 20 '13 at 9:50
1  
For me, indicator-datetime was already installed after the upgrade. The last two commands solved the issue though, thanks. –  Ove Øyås Jan 21 at 12:50
2  
no need to login / logout. fixed automatically. tks UPVOTED :) –  tony gil Apr 12 at 9:55

Go to Time & Date under System Settings, and after you click on it, click on the Clock tab, and make sure that there is a check mark in Show a clock in the menu bar. See image below.

enter image description here

share|improve this answer
11  
The entire panel is greyed out –  Paté Oct 12 '13 at 18:59
4  
If the whole panel is grayed out, try (as mentioned already in another answer) the following commands in a terminal: sudo dpkg-reconfigure --frontend noninteractive tzdata && sudo killall unity-panel-service –  user221931 Apr 7 at 0:22

run sudo apt-get install gnome-control-center. If it is un-installed, install it. Then for date-time install the package indicator-datetime.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.