Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So far I have tried to install Kubuntu 32 Bit Kubuntu 64 Bit Fedora 64 Bit and Linux Mint 64 Bit (no dualboot)

System Specs:

  • AMD Fx-6300
  • Gygabite 970A-UD3
  • 160 GB SATA Hard Drive
  • Radeon HD 4800
  • 4 GB DDR3 Ram

I could install Kubuntu 32 Bit without problems but than i tried installing the 64 Bit Version and it always prompted the error

(initramfs) Unable to find a medium containing a live file system

After reading that it used to happen on usb3-ports i checked and it happens for me only on the usb2 ports. When i plug it in the usb3 Port the installation starts. But at the end it prompted the failure:

Failed to install grub-efi to /target/

Than I installed kubuntu 64 bit out of the Live System and it succeeded. Apparently. When I tried to boot from the hard drive nothing happened. Just a blinking minus.

So I reinstalled grub2 in chroot and it succeeded again. But again, it will not start.

So I checked a script that I found on a forum which will show me the destination of the grub bootloader and it found nothing.

So out of desperation I tried other Linux Versions. Fedora will not start at all, and linux mint starts the live system but when I install it, it failed to install grub-efi again (with error message).

Also I have the problem that my internet connection doesn't work when i load into a live system.

  • Is there someone who has another idea? I just want a running 64 Bit Version of Kubuntu.

Sorry for bad english (not my native language)

Update

I got Internet working by activating the IOMMU in the bios. I also get rid of the (initramfs) Unable to find a medium containing a live file system error if I plug the usb drive in a USB2 Port.

Unfortunately I am still stuck with the Grub error.

Update 2

According to this Thread it is not possible for me to install 13.04 due to a bug in Grub. So I installed Kubuntu 12.10 64-Bit and it worked! At the moment I am upgrading my OS to 13.04 and then I hope it is working...

share|improve this question
    
Since you are not dual booting, have you tried turning off uefi in your BIOS? –  kenbonilla Oct 12 '13 at 13:47
    
I get stuck with the Failed to install grub - error again. I set "Boot Mode Selection" to "Legacy Only" (from "UEFI and Legacy") The Tooltip says: "This option controls what devices system can boot to" Is this enough or should I look for another option? –  flip Oct 13 '13 at 12:30
    
Please don't put "solved" in the question title. Instead, mark the answer that was most helpful as correct. That is how this site works. If there's no answer present yet, add your own. –  gertvdijk Oct 13 '13 at 18:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.