Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi guys I just installed ubuntu 13.04 on my Dell inspiron 5520 laptop the WiFi worked fine when i booted from the live cd and installed it got the timezone and some updates too.

but after installation there is no trace of WiFi connectivity.

also the bluetooth settings seems to be just for show. It wont detect any other device and I cant find it on any other device

i ran sudo lshw -c network and the output was

*-network
   description: Ethernet interface
   product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:07:00.0
   logical name: eth0
   version: 05
   serial: d4:be:d9:2d:d7:49
   size: 10Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:43 ioport:2000(size=256) memory:c1404000-c1404fff memory:c1400000-c1403fff

*-network UNCLAIMED
   description: Network controller
   product: BCM43142 802.11b/g/n
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:08:00.0
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: latency=0
   resources: memory:c1500000-c1507fff

`

also i ran lspci | grep -i bcmand the output was

 `08:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)`

also the rfkill list command gave this output

  1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

`

iwconfig command says that there is no wireless extensions.

I have installed ubuntu 13.04 on an external USB hard drive.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

OK I Didnt know that Ubuntu was a little dumb...

while installing the WiFi worked, not sure why, but in Additional drivers tab the device was disabled even though a driver was present.

Shouldn't the default behavior be to enable device even if the only driver available is a proprietary one.

All i had to do was go there and select the driver.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.