Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install curl in my ubuntu server as I was getting this error -

fatal error: curl.h: No such file or directory

Below is the error -

username@phx7b02c-ee1b:~$ sudo apt-get install libcurl4-gnutls-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4-gnutls-dev : Depends: libldap2-dev but it is not going to be installed
E: Broken packages

I am not sure what wrong I am doing here?


My ubuntu version -

username@phx7b02c-ee1b:~$ uname -a
Linux phx7b02c-ee1b 2.6.35-22-server #33-Ubuntu SMP Sun Sep 19 20:48:58 UTC 2010 x86_64 GNU/Linux
share|improve this question
When you say 'trying to install' - you want to install from source, not from a package? Any particular reason? – poolie Oct 11 '13 at 22:17
What Ubuntu version are you using? Do you have any nonstandard repositories added? – poolie Oct 11 '13 at 23:41
What happens if you try manually sudo apt-get install libldap2-dev? – poolie Oct 11 '13 at 23:41
If I do sudo apt-get install libldap2-dev then I get another error with the same format The following packages have unmet dependencies: libldap2-dev : Depends: libldap-2.4-2 (= 2.4.23-0ubuntu3) but 2.4.23-0ubuntu3.5 is to be installed E: Broken packages – lining Oct 11 '13 at 23:55
Updated my question with ubuntu version.. Not sure about repositories at all.. – lining Oct 11 '13 at 23:56

Similar to other questions about "some packages could not be installed", try

apt-get update
apt-get autoremove
apt-get install -f
share|improve this answer
still the same error... I did all the above commands.. – lining Oct 11 '13 at 22:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.