Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to install Skype. Everytime I get this error:

bilal@bilal-HP-ProBook-4520s:~$ sudo dpkg -i getskype-*
(Reading database ... 143630 files and directories currently installed.)
Preparing to replace skype 4.2.0.11-1 (using getskype-linux-beta-ubuntu-32) ...
Unpacking replacement skype ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libqt4-webkit (>= 4:4.5.3); however:
  Package libqt4-webkit is not installed.
 skype depends on libxss1; however:
  Package libxss1 is not installed.
dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 skype
share|improve this question
1  
Have you tried sudo apt-get install libxss1 libqt4-webkit –  minerz029 Oct 12 '13 at 3:10
add comment

1 Answer

Users of 64-bit Ubuntu, should enable MultiArch if it isn't already enabled by running the command

$sudo dpkg --add-architecture i386

Since Ubuntu 10.04 (Lucid Lynx), Skype is part of the Canonical partner repository. To install Skype add the Canonical Partner Repository. You can do this by running the command

$sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

Then install Skype via the Software-Center or via the Terminal.

$sudo apt-get update && sudo apt-get install skype

It is highly recommended to use the package provided in the Canonical partner repository, not the one distributed from the skype website, as the skype website currently points users to the wrong package for 64-bit systems of Ubuntu 11.10 and above.

This document might help you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.