Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu server 12.04 LTS and i have a network IP address but no internet connection. lampp, ssh, work fine over the network but i can't talk to anything outside of my network.

output from ifconfig

eth0      Link encap:Ethernet  HWaddr bc:5f:f4:90:44:fa  
          inet addr:192.168.1.150  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::be5f:f4ff:fe90:44fa/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:232675 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56829 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:73760265 (73.7 MB)  TX bytes:7406332 (7.4 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:63887 errors:0 dropped:0 overruns:0 frame:0
          TX packets:63887 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5215210 (5.2 MB)  TX bytes:5215210 (5.2 MB)

virbr0    Link encap:Ethernet  HWaddr 32:31:e1:32:89:75  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

output from route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0
share|improve this question

closed as off-topic by poolie, Braiam, psusi, qbi, Jorge Castro Oct 15 '13 at 21:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Braiam, psusi, Jorge Castro
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Can you add to your question the output of running in a terminal the ifconfig and route -n commands? Open a terminal with ctrl-alt-t, run the commands one at a time, then copy and paste the text in the question. –  roadmr Oct 11 '13 at 20:43
1  
The Ubuntu network configuration seems fine, so I concur with Doc Fubar that the problem is elsewhere, either the router's configuration or the external internet connection itself. –  roadmr Oct 11 '13 at 21:11
    
If you do ping -c2 192.168.1.1 it should answer you. Then try ping -c2 4.2.2.2. –  Braiam Oct 12 '13 at 0:21

1 Answer 1

That sounds like a mac address filter running in the router security settings. Unless your Mac address is entered in the list, any WAN connection gets denied.

Check the router firewall settings.

share|improve this answer
    
it had something to do with my static ip. I just set it back to auto. Seems to be working fine now. –  ltshineysidez Oct 11 '13 at 22:46
    
I suspect, in your static setup, which is preferred for a server, that you failed to set DNS nameservers. –  chili555 Oct 11 '13 at 23:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.