Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been having some annoying issues due to downloading on Ubuntu and terminal. I understand and have seen all questions and answers of my issue and "none" have worked at all.

I am currently using version 13.04. Every time i try going into the terminal I get errors via apt-get update:

E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/ E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
jack@jack-M17x:~$

sudo apt-get update shows up with:

Err http://gb.archive.ubuntu.com raring Release.gpg
Could not connect to localhost:4001 (127.0.0.1). - connect (111: Connection refused)

W: Some index files failed to download. They have been ignored, or old ones used instead."

(more links are displayed with "err" via localhost. My internet is fine running at 120mbs.

And when trying to install something on the software centre i get Failed in install Package check your internet connection.

I've mostly tried all the answers and tricks given on the forums and nothing seems to work. Furthermore,I have tried re-installing Ubuntu, and it cannot find the kernel or just won't boot up from using my USB.

share|improve this question
3  
In order for people to be able to answer you, they'll need something to work with. Maybe run sudo apt-get update from a terminal ( Ctrl+Alt+T) for a start - post the output here. –  Elfy Oct 11 '13 at 19:01
1  
Which version of Ubuntu are you running? –  To Do Oct 11 '13 at 20:50
1  
Can you edit your question and add the output of cat /etc/apt/sources.list, ping -c 2 gb.archive.ubuntu.com, grep Proxy /etc/apt/apt.conf.d/*. –  Braiam Oct 13 '13 at 12:15
1  
@ToDo judging by the error message when he runs sudo apt-get update, I'm guessing raring. –  Thomas W. Oct 13 '13 at 17:20
    
Can you add the output of grep -i proxy /etc/apt.conf.d/*? –  Braiam Oct 14 '13 at 20:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.