Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to find a solution for a few days, I hope someone can answer me. I tried several times to install flash player through lubuntu software center, and after I hit "Install Packages" it gives me an error:

 Failed to load the package list
This is a serious problem. Try again later. If this problem appears again, please report an error to the developers. >Details E:Type 'sudo' is not known on line 60 in source list /etc/apt/sources.list .

I think that I accidently, couple weeks ago, tried to add reposetories to my sources.list and I saved it. If this the problem, is there a way to make a new sources.list?

share|improve this question
1  
Does your /etc/apt/sources.list file contain a line starting with sudo? This file should normally contain only lines starting with deb or deb-src and comments starting with #. –  chronitis Oct 11 '13 at 12:53

1 Answer 1

The line 60 of your sources.list has something that it shouldn't have. You can fix the line using sed:

sudo sed -e '60d' /etc/apt/sources.list

The -e edit the file in place, the 60 indicates the line, d indicates that stop right there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.