Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I think the issue is related to driver, output is following for:

lspci -nnk | grep -iA2 net

07:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4365] (rev 01) Subsystem: Dell Device [1028:0016] 09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 07) Subsystem: Dell Device [1028:0556] Kernel driver in use: r8169

Using Ubuntu 11.1 on dell vostro 2420.

Tried downloading bcmwl-kernel-source and b43-firmware and all other combinations of it; in all possible scenarios like uninstalling kernel while trying b43 Downloaded all possible driver souces as well as packages, but of no use.

My wired network is all fine, even bluetooth is working fine but wireless is not showing. followed and tried almost all threads with the similar tags or topics, but of no use. Plz share solution...

(edited) Luckily i could get rid of it just after the last try I made after posting this question.

Finally I did-

Remove DKMS Framework from Software Center and installed wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb (found this here http://jas.gemnetworks.com/debian/pool/main/w/wireless-bcm43142/wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb)

had to install this twice; because when you install it once it responds install the package if you trust the provider then you've to again click install once again and rebooted system, wireless interface found up and running... Quite relieved after a 20 hrs troubleshoot session. :)

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.