Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just downloaded Ubuntu 13.10 final beta 64 bit and every program that I use work flawlessly with the exception of "Machinarium" a very cool flash game. The game doesn't have a .deb package and I used to be able to play it before. I tried installing lib32 and ia32 and it says it is installed to the last version or if I try lib32-dev it says that is no longer available. Here is my ldd command result:

fz@Unknown:~/Games/Machinarium$ ldd Machinarium
    linux-gate.so.1 =>  (0xf77c8000)
    libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf76c0000)
    libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf76a5000)
    libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf756f000)
    libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf755c000)
    libXt.so.6 => /usr/lib/i386-linux-gnu/libXt.so.6 (0xf7500000)
    libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6 (0xf7461000)
    libfontconfig.so.1 => /usr/lib/i386-linux-gnu/libfontconfig.so.1 (0xf7427000)
    libgtk-x11-2.0.so.0 => not found
    libgdk-x11-2.0.so.0 => not found
    libatk-1.0.so.0 => not found
    libgdk_pixbuf-2.0.so.0 => not found
    libpangocairo-1.0.so.0 => not found
    libpango-1.0.so.0 => not found
    libcairo.so.2 => not found
    libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0 (0xf73d3000)
    libgmodule-2.0.so.0 => /usr/lib/i386-linux-gnu/libgmodule-2.0.so.0 (0xf73ce000)
    libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf73c9000)
    libglib-2.0.so.0 => /lib/i386-linux-gnu/libglib-2.0.so.0 (0xf72c4000)
    libnss3.so => not found
    libsmime3.so => not found
    libssl3.so => not found
    libplds4.so => not found
    libplc4.so => not found
    libnspr4.so => not found
    libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7280000)
    libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7263000)
    libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf70b0000)
    libXrender.so.1 => /usr/lib/i386-linux-gnu/libXrender.so.1 (0xf70a4000)
    /lib/ld-linux.so.2 (0xf77c9000)
    libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf7083000)
    libSM.so.6 => /usr/lib/i386-linux-gnu/libSM.so.6 (0xf707a000)
    libICE.so.6 => /usr/lib/i386-linux-gnu/libICE.so.6 (0xf7060000)
    libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf7046000)
    libexpat.so.1 => /lib/i386-linux-gnu/libexpat.so.1 (0xf701c000)
    libffi.so.6 => /usr/lib/i386-linux-gnu/libffi.so.6 (0xf7015000)
    libpcre.so.3 => /lib/i386-linux-gnu/libpcre.so.3 (0xf6fd4000)
    libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf6fd0000)
    libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf6fc9000)
    libuuid.so.1 => /lib/i386-linux-gnu/libuuid.so.1 (0xf6fc2000)
share|improve this question

closed as off-topic by Braiam, blade19899, BuZZ-dEE, mikewhatever, Eric Carvalho Jan 12 at 16:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, blade19899, BuZZ-dEE, mikewhatever, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please edit your question and state what happens when you try to run the game. Please post the full error-message if there is one. –  MadMike Oct 11 '13 at 7:07
    
fz@Unknown:~/Games/Machinarium$ '/home/fz/Games/Machinarium/Machinarium' /home/fz/Games/Machinarium/Machinarium: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory –  Fonz Oct 11 '13 at 7:13
    
You should just be able to do sudo apt-get install packagename:i386 for the missing libraries to get 32-bit versions (AFAIK) (although that doesn't guarantee that appropriate library versions are still available). –  chronitis Oct 11 '13 at 13:19
    
Package ia32-libs:i386 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: lib32z1 lib32ncurses5 lib32bz2-1.0 –  Fonz Oct 12 '13 at 2:56
1  
"Ubuntu 13.10 final beta 64 bit", have you tried with an stable? –  Braiam Jan 11 at 13:09
show 1 more comment

3 Answers 3

apparently you have to install the libgtk2.0-0:i386 package.

sudo apt-get install libgtk2.0-0:i386
share|improve this answer
add comment

There are 2 options to run Machinarium on Ubuntu 13.10 64bits.

Deb Package

If we have the .deb package (and yes! it is a 32bit package).

You must to install it with Ubuntu Software Center (not using dpkg -i), so simply double click the file.

To remove the game

sudo dpkg -r machinarium 

TAR.GZ version

If you have the tar.gz version.

You need to install all those libraries.

sudo apt-get install libgtk2.0-0:i386 libnss3:i386 libcurl3-gnutls:i386 libidn11:i386 libpango1.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 librtmp0:i386 libxft2:i386

Run it on STEAM

In both cases if you want to run it with STEAM as a NO Steam game, you must to install also this last library.

sudo apt-get install libxtst6:i386
share|improve this answer
add comment

I have the same problem here. This is not exactly a solution, but I'll try to add some information.

I tried @AdamOutler solution but after installing libgtk2.0-0:i386 another dependencies were need which I solved installing libnss3:i386 and gtk2-engines-murrine:i386. The problem was when the next step required a package called unity-gtk2-module:i386 that depends on unity-gtk-module-common:i386 which doesn't exists anymore.

I abandoned this approach and found that I could install the game directly from the Software Center (as I bought it from Humble Bundle). It worked like a charm! The crazy part is that there's no apparent difference between installations (.TGZ vs .DEB) - files inside folder looks to be the same (used file and md5sum commands to check).

Here is the list of dependencies from the installed package: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.4), libcairo2 (>= 1.2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.12.0~1.9b1), libpango1.0-0 (>= 1.14.0), libstdc++6 (>= 4.1.1), libx11-6, libxext6, libxrender1, libxt6, libcurl3-gnutls

One last thing is that I'd suggest to try to create a launcher for the game because I still have no success starting the game from bash.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.