Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to set up PHP behind Nginx with FastCGI but I stuck on the sudo apt-get -f install php5-fpm

what i've tried:

sudo apt-get -f install php5-fpm 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-fpm : Depends: php5-common (= 5.3.10-1ubuntu3.8) but 5.4.6-1ubuntu1.4 is to be installed
E: Unable to correct problems, you have held broken packages.

my source-list (this server is restricted to Ukrainian network only, no connecting to the world)

deb http://mirror.yandex.ru/ubuntu precise universe
deb http://mirror.yandex.ru/ubuntu precise-updates universe

deb http://mirror.yandex.ru/ubuntu quantal-security main restricted
deb-src http://mirror.yandex.ru/ubuntu quantal-security main restricted
share|improve this question
    
Why you have precise and quantal repositories? –  Braiam Oct 10 '13 at 23:48
    
@Braiam yes i did... –  dvrecmfo Oct 10 '13 at 23:49
    
quantal-security main restricted because I need php5-fpm... and precise universe because yandex don't have main restricted –  dvrecmfo Oct 10 '13 at 23:57
add comment

1 Answer

up vote 0 down vote accepted

The problem is that you are mixing repositories of different versions. You should not ever do that!

precise universe because yandex don't have main restricted

Yandex repository is complete with main, restricted, universe and multiverse in all the precise precise-updates and precise-security as can be seen here:

enter image description here

enter image description here

enter image description here

After you have fixed your repositories, just do sudo apt-get update and it will be fine.

quantal-security main restricted because I need php5-fpm

Precise has the package!

http://packages.ubuntu.com/search?keywords=php5-fpm

share|improve this answer
    
lets say i place only precise universe than i can't install php5 sudo apt-get install php5 E: Package 'php5' has no installation candidate –  dvrecmfo Oct 11 '13 at 0:16
    
@dvrecmfo of course, php5 is in main repositories, you should put something like this: paste.ubuntu.com/6220331 –  Braiam Oct 11 '13 at 0:22
    
oh now I get it, thanks. –  dvrecmfo Oct 11 '13 at 0:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.