Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to Ubuntu 13.10, with the new keyboard handling system. The little "switch keyboard" option does not let me set it to Alt+Shift. How can I get this keyboard binding, as I have absolutely no interest in using the Mac-esque Super+Space combo?

share|improve this question
add comment

3 Answers

up vote 77 down vote accepted

A confirmed bug in Ubuntu 13.10 prevents users from switching layouts using combinations like Alt+Shift, Caps Lock, Ctrl+Shift etc.

The bug affects many people, its importance is set to "High", so we may expect that an official fix will be released soon. You can subscribe to notifications about this bug on launchpad.net, so that you receive an email when it's done.

Currently, a patch aimed at resolving this issue is being tested. By now it seems to work for most users, though certain problems remain. To install the patch, use the following commands:

sudo add-apt-repository ppa:attente/modifier-only-input-switch
sudo apt-get update
sudo apt-get upgrade

A system reboot was needed in my case to make it work (simple log out and log in may be sufficient).

Note: Originally, the patch was located at ppa:attente/1218322. If you have previously installed it from there, you can first purge it as follows

sudo ppa-purge ppa:attente/1218322

and then execute the three commands above.

Alternatively, you may consider using a combination containing a non-modifier key (a letter, digit, space): try, for instance, Alt+Shift+Space (this will work without installing any patches).

Note that the keyboard shortcuts for switching layouts still do not work on lock screen (it is a separate bug). If you are stuck on lock screen and unable to enter the password because of the wrong layout, simply click the language indicator icon on the right of the password field.

share|improve this answer
1  
I installed the attente's patch hoping that it could bring back my beloved (Left ALT) switch combo. But after reboot it did not work as expected. –  alfish Oct 23 '13 at 11:20
3  
Thanks for this, really frustrating how such an essential thing was broken –  rtpg Oct 25 '13 at 16:49
    
Creator of the ppa says it has been superseded by this one –  chaskes Nov 13 '13 at 16:23
    
@chaskes Thank you, updated the answer –  Georgy Ivanov Nov 13 '13 at 17:00
    
Did not work for me with Ubuntu GNOME 13.10 :( –  MIH1406 Dec 19 '13 at 17:18
show 2 more comments

Many thanks to William Hua (attente) for his Modifier-only input switch PPA. As he said, he will keep the PPA up-to-date until a correct fix for this bug is released.

After I added this PPA to my list of sources using the following command:

sudo add-apt-repository ppa:attente/modifier-only-input-switch

and after I upgraded my system using:

sudo apt-get update
sudo apt-get upgrade

I could change the default Super+Space keyboard shortcut to Alt+Shift:

Text Entry

share|improve this answer
    
Worked for me after a reboot, thanks –  Kibi Oct 24 '13 at 11:51
    
Creator of the ppa says it has been superseded by this one –  chaskes Nov 13 '13 at 16:25
add comment

In Ubuntu 12.04 LTS, in the Keyboard Layout Options window I could select Key(s) to change layout and mark the binding of my choice. I use Shift + CapsLock to toggle the layout from the keyboard itself without having to use mouse cursor to select the required layout from the panel indicator. The same key combo seemed to work to serf through or select between multiple layouts. (But in Ubuntu 13.10 it wasn't so easy.) snap5


In Ubuntu 13.10

In the Keyboard settings window, under Shortcuts tab, I select Typing. The default for Switch to next source is Super+SPACE which didn't seem be working for me and so by clicking on it and I assigned a New Accelerator..., to change to next Layout (I used Super+L).

(Then I assigned something similar for Switch to previous source using the same preferred layout, and then began to test them. Switching from the preferred layout to the alternate worked but the reverse did not. Please refer the next step for the fix.) saucy1

The Fix: After assigning Super+L for "Switch to next source" using my preferred layout (A), I changed my keyboard layout to the alternative layout (B) and then assigned the combination to "Switch to previous source" (for which I used Shift+Super+L). Then I tested them, and they work fine. (Maybe disabling "Switch to previous source" would work too.)

The new accelerators for the key combos that I used looks like this: saucy2

I could then switch to layout (A) using Super+L and back to layout (B) using Shift+Super+L.

share|improve this answer
add comment

protected by Community Oct 23 '13 at 0:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.