Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Due to some work I have to setup a DNS server

I am following a guide here http://lani78.wordpress.com/2012/07/22/setting-up-a-dns-for-the-local-network-on-the-ubuntu-12-04-precise-pangolin-server/

my network is in range of 192.168.1.2-27 connected via an ADSL router with wifi, (I basically want to PXE boot windows using unattended ) so I am setting up all this I made following changes to the laptop which I want to make bind9 server

auto lo
iface lo inet static
        address 192.168.1.7
        netmask 255.255.255.0
        gateway 192.168.1.1
        network 192.168.1.0
        broadcast 192.168.1.255
        dns-nameservers 127.0.0.1
        dns-search home.lan
        dns-domain home.lan

I have eth0 and wlan0 as interfaces on above machine so I doubt if the above changes were correct. Making above entries to the interfaces file caused ssh to stop working i.e. I could not ssh to above bind9 server from other machines in my network. Putting things back to following

auto lo
iface lo inet loopback

I was able to get ssh back on target machine.

Now I did /etc/network/interfaces based on a template here

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
  address 192.168.1.7
  netmask 255.255.255.0
  gateway 192.168.1.1
  network 192.168.1.0
        broadcast 192.168.1.255
        dns-nameservers 127.0.0.1
        dns-search home.lan
        dns-domain home.lan

but here I was totally disconnected from the wireless, so I had to put back original settings

auto lo
iface lo inet loopback

I notice here it says

 By default, NetworkManager does not manage interfaces that appear in /etc/network/interfaces.

if that is the case then by default where do people put in entries if they want their machines to have a static ip, in my case I have 2 network interfaces. I want to know what is wrong in my configuration and for client machines what should I set?

I have also tried setting up of static ip for wireless interfaces by a guide here the configuration looked as follows

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
      address 192.168.1.7
      netmask 255.255.255.0
      broadcast 192.168.1.255
      gateway 192.168.1.1
      wpa-ssid bsnl2
      wpa-psk e61b988cf433a0275de2a0ea569417479adb1b49698f432152cc1c5a901369ce

but upon reboot I found my wireless connection broken so I had to revert back to

auto lo
iface lo inet loopback

What is the mistake I am doing?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.