Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use gpg-agent (and its gpg.conf and gpg-agent.conf files) when I invoke gpg (from Enigmail or otherwise) but Ubuntu 12.04 uses seahorse as the default 'agent.' While seahorse may or may not read these conf files, how can I force gpg to bypass Ubuntu's setup and use gpg-agent?

This is what I see when I ask the terminal to return $GNU_AGENT_INFO:

user@user:~$ echo $GNU_AGENT_INFO  
/tmp/keyring-xxxxxx/gpg:0:1  

Following the gpg man page, I have tried adding the following lines to my gpg.conf file without desired result:

--gpg-agent-info=/usr/bin/gpg-agent  
--gpg-agent-info=/usr/bin/gpg-agent:0:1  

Thanks.

PS: In addition, does seahorse use equivalent files of the same path and name (gpg.conf, gpg-agent.conf)? If not, what are the paths and names I could use to reach equivalent result?

share|improve this question

1 Answer 1

As per this answer:

sudo mv /etc/xdg/autostart/gnome-keyring-gpg.desktop /etc/xdg/autostart/gnome-keyring-gpg.desktop.disabled

This worked for me on Ubuntu 13.04. It disables the gpg part of gnome keyring.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.