Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ubuntu 13.04 server and want to connect to my network via wifi. At boot I get "Waiting for network configuration..." and "Waiting up to 60 more seconds for network configuration...". However my wifi LED is not turned on and get no connection.

When I run

sudo service networking restart

the wifi LED is turned on and I connect quickly.

This is my /etc/network/interfaces:

auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet dhcp
    wpa-ssid MySSID
    wpa-psk  MyPassword

Do you have any idea how to connect immediately at boot?

Edit:

My dmesg output

share|improve this question

1 Answer 1

You should be able to get it added to the boot-up routine with the following:

sudo update-rc.d networking defaults

If that doesn't work or if it tells you it's already there, make sure it isn't crashing at bootup. This will show you error messages in the log:

dmesg | tail 40

You can find more helpful information about starting services at boot-up time here.

share|improve this answer
    
Unfortunately this did not help. I added my dmesg output to the original question, but could not detect anything promising. Maybe in line 749: "wlan0: link is not ready"? –  ACNB Oct 10 '13 at 7:58
    
Based on your dmesg I wonder if your networking service is starting too soon. Try changing the order so it starts last (this is old but may help: serverfault.com/questions/193115/…). You may also try disabling IPv6 since that is what it complained about: askubuntu.com/questions/309461/how-to-disable-ipv6-permanently –  Freedom_Ben Oct 10 '13 at 16:28
    
Thanks, but still no success. http:://pastebin.com/x0yxpnNv - dmesg –  ACNB Oct 11 '13 at 11:50
    
Wow I'm running out of ideas :-O Try running sudo service networking restart as an upstart task and see if that does it askubuntu.com/a/1135/136192 . In the script you probably want the first line #!/bin/bash and the second line sudo service networking restart –  Freedom_Ben Oct 11 '13 at 13:20
    
I've now installed ubuntu 12.04 and everything works well. The LTS version seems to be much more stable. Thank you very much for helping anyway. –  ACNB Oct 12 '13 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.