Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from 12.04 to 13.10, and after that, my secondary monitor doesn't work anymore.

A little more info:

$ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024       0.0* 
   1024x768        0.0  
   800x600         0.0  
   640x480         0.0  

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560 Ti] (rev a1)

$ sudo lshw -C video
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: GF114 [GeForce GTX 560 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f4000000-f5ffffff memory:e8000000-efffffff memory:f0000000-f3ffffff ioport:e000(size=128) memory:f6000000-f607ffff

Even at login screen, it doesn't detect it at all.

So, anyone knows how to fix this?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Solved this issue searching for another display-related problem on this upgrade. here are the steps:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-331 nvidia-settings-331

And then restart the computer

share|improve this answer
    
The PPA says that you shouldn't install packages from it separately. Just FYI. –  the_drow Dec 5 '13 at 9:47

I had the same problem and sort of panicked but all I had to do was go to control panel, click on Adjust screen resolution under Appearance and Personalization.

Then adjust monitor 1, monitor 2 and so on accordingly!

Hope this helps

share|improve this answer
1  
Sadly, that didn't work, the other display wasn't even there. –  guinunez Oct 15 '13 at 18:25
    
Ok, I just searched a solution for another display-related problem: mouse flickering. Reinstalled the ppa repository and installed nvidia 331 drivers. That solved the multiple-monitor issue as well –  guinunez Oct 15 '13 at 18:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.