Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 13.04. Trying to install new software but I see only use the source code in Ubuntu software center. There is no install option. And I am trying to install few plugins for browser its not working. I tried using WiFi as well as wired connection.

Tried following things after reading same kind of problems on net- 1.

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock

2. system-> administration-> software sources could not find this path.

3. sudo apt-get update then again tried

None of these helped me.

Any suggestion would be very thankful.

share|improve this question

closed as unclear what you're asking by Alvar, guntbert, Warren Hill, Braiam, Eric Carvalho Oct 15 '13 at 2:14

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
possible duplicate of How to install a .tar.gz (or .tar.bz2) file? –  Alvar Oct 10 '13 at 11:59
1  
What new software (from where?) do you try to install? Did you download something? –  guntbert Oct 13 '13 at 10:58
    
"I see only use the source code in Ubuntu software center" I'm absolutely sure that you do not see only source code in the USC. You see free (as freedom) software. USC don't download source code of packages, only CLI utils do this. –  Braiam Oct 14 '13 at 14:15

1 Answer 1

If there is only source code, you have to compile it on yourself's.

Download the source code, open a terminal and cd to the download directory. (If it's an archive, extract it first.) Now use the following commands:

./configure
make
make install

If everything goes fine, the program should be installed.

Software Sources is to include other PPA's, not to install the software itself.

share|improve this answer
    
Hi Thank you for your reply. I tried what you said. When I enter make following message appeared - make: *** No targets specified and no makefile found. Stop. –  shaik Oct 10 '13 at 9:27
    
In addition to the above problem, I am not able to create ubuntu one and ubuntu software center accounts as captcha is not loading at all. How to solve this problem –  shaik Oct 10 '13 at 9:37
    
Maybe I expressed myself a bit unclearly: You have to cd into the direcory you downloaded. And sorry, there isn't a ` abfter configure. To your Captcha problem: Do websites load much faster than the Captcha? –  the_Seppi Oct 10 '13 at 11:41
    
I am going in ti the director by using the command cd then started doing the process. But its saying unable to find package. –  shaik Oct 11 '13 at 4:51
    
my internet is pretty fast for browsing, but these captcha are not at all loading –  shaik Oct 11 '13 at 4:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.