Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 LTS and a NAS (QNAP TS-219P+) (IP adress: 192.168.0.111) on which SAMBA is running.

I wanted to mount some files of the NAS using mounting points in /media. So I created for each NAS file a corresponding file in /media for example connecting NAS/transfer to /media transfer using chown and chmod. In fstab I added the necessary line, for example:

//192.168.0.111/transfer /media/transfer cifs user=juergen,passwd=1234 0 0 

and so on

In Nautilus the NAS file is initially shown as mounted in 'Geräte' (german). In English I think it would be 'Devices'. After a short while the mounted file appears in 'Rechner' (in German language). In English I think it should be 'Computer'.

I can access the NAS files. But I am not able to change the owner and the user of for example /media/transfer from root root to juergen juergen. Using the command sudo chown -c juergen /media/transfer in the terminal line it is said that root root has changed to juergen juergen but using the command ls -l again root is shown as the owner.

Comment: I am using Ubuntu only for some months.

share|improve this question
    
user200179 - if you are the person who has added two answers which have now been deleted, please use the contact us link at the bottom of this page to ask for all of your accounts to be merged. Once done, you'll be able to edit your question with further details. Thanks. –  fossfreedom Oct 15 '13 at 13:59
add comment

1 Answer 1

You are trying to change ownership of a mountpoint; I don't know if that's possible, but neither I see the use of that.

I guess what you want to achieve is to be able to access R/W the files on the remote drive as juergen, not only as root. In that case, add the uid option to your fstab line:

//192.168.0.111/transfer /media/transfer cifs user=juergen,passwd=1234,uid=juergen 0 0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.