Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created a project on Sourceforge. When I try to checkout, I get the following error:

$ svn checkout --username=hopungo svn+ssh://hopungo@svn.code.sf.net/p/slkrepair/code-0/ slkrepair-code-0
ssh: connect to host svn.code.sf.net port 22: Connection timed out
svn: E210002: Unable to connect to a repository at URL 'svn+ssh://hopungo@svn.code.sf.net/p/slkrepair/code-0'
svn: E210002: To better debug SSH connection problems, remove the -q option from 'ssh' in the [tunnels] section of your Subversion configuration file.
svn: E210002: Network connection closed unexpectedly

I used suggestion from How to use svn list svn+ssh://user@host/home/svn/myrepo without SVN_SSH path., but got such output:

Warning: Identity file /home/karimov-danil/.ssh/id_rsa not accessible: No such file or directory.

My ~/.subversion/config [targets] section is:

ssh = ssh -l hopungo -i /home/karimov-danil/.ssh/id_rsa

and my /etc/environment has such lines:

http_proxy="http://cache.mrk:8080/"
https_proxy="https://cache.mrk:8080/"
ftp_proxy="ftp://cache.mrk:8080/"
socks_proxy="socks://socks.mrk:1080/"

Where did I mistake? What options should I configure?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.