Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running a 12.04 64bit config on a T430. Bumblebee/optirun are functioning well: Glxgears normally: 61.037fps Glxgears optirun: 1135.062

If a co-worker drops her windows laptop into my docking station the DVI ports work fine so it's not the dock. I'm pretty sure my laptop is fine as well but can't verify it that I know of.

If I run "sudo optirun -b auto nvidia-settings" it says it doesn't see me running a NVIDIA X driver. There is also nothing in the Ubuntu Display control panel for the monitors.

share|improve this question

2 Answers 2

It's possible that some of the ports (i.e. the dvi ports) are connected directly to the nvidia graphics card rather than the integrated intel card that runs the thinkpad display. This was the case with my W530 - see my blog post here: http://zachstechnotes.blogspot.com/2012/01/tri-head-display-on-linux-thinkpad-w520.html

The primary function of Bumblebee is to render graphics on the nvidia card and send that image to the intel card to show on your thinkpad display. In order to use the digital outputs, you'll need to send the data to the external monitor through the nvidia card. There are various workarounds to accomplish this, however they aren't super straightforward. If you want to move forward with one of those workarounds, leave a comment and I can expand my answer and point you in the right direction.

share|improve this answer
    
Well, If he doesn't want to know, I sure do. –  Peaches491 Oct 14 '13 at 21:18
    
I would definitely be interested in taking a shot at this as I would like my two other monitors working and there are likely others aw well. –  user199977 Oct 17 '13 at 20:11
    
alright, this is going to require some back and forth, and I don't check this often enough, so could one of you send me an email at sunbergzach ( at ) gmail (dot) com. That's a much better way to communicate. I'll update the answer for everyone at the end. –  Zach Oct 18 '13 at 2:52
    
The first instruction is to reboot and enter your bios (you have to press the F12 key when the Thinkpad screen comes up). Go into the setup menu, and somewhere in there, there should be a display settings option that allows you to choose between Integrated Graphics, Discrete Graphics, and NVIDIA Optimus. Choose Discrete Graphics and reboot. Then try to see if you can get your dvi monitors working using either the built in ubuntu tools, or nvidia-settings. If you make an xorg.conf with nvidia-settings, you will have to delete it to get back your old settings. Let me know how that goes. –  Zach Oct 18 '13 at 2:55
    
If anyone with a T-430 happens upon this, you should try this workaround, and see if it works sagark.org/optimal-ubuntu-graphics-setup-for-thinkpads –  Zach Oct 24 '13 at 1:13

I'm also interesed in this stuff. However, I don't think the method Zach recommended still works as indicated last parts in the comments. (Precisely speaking, from the "patch" process to make virtual monitor for xrandr.) I tested with Ubuntu 12.04.3 on T520 and T430 (also with Linuxmint 15), which ends up not even showing the login screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.