Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try loggin in my account e only a black screen is showing for me. Analizing .xsession-errors file:

localuser:desenvolvimento being added to access control list
Script for cjkv started at run_im.
Script for default started at run_im.
Script for cjkv started at run_im.
Script for default started at run_im.
x-session-manager[3589]: WARNING: Unable to find required component 'gnome-shell'
x-session-manager[3589]: CRITICAL: We failed, but the fail whale is dead. Sorry....
x-session-manager[3589]: WARNING: Failed isActive call to ConsoleKit: Rejected send message, 2 matched rules; type="method_call", sender=":1.80" (uid=1000 pid=3589 comm="x-session-manager ") interface="org.freedesktop.ConsoleKit.Manager" member="IsActive" error name="(unset)" requested_reply="0" destination=":1.21" (uid=0 pid=1375 comm="/usr/sbin/console-kit-daemon --no-daemon ")

trying reinstall gnome-shell

$ sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell : Depends: gnome-settings-daemon (>= 3.8.0) but 3.6.4-0ubuntu8 is to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install --reinstall gnome-shell => Above error $ sudo apt-get -V dist-upgrade => nothing $ sudo apt-get changelog => E: Handler silently failed $ sudo apt-get autoremove => notning $ sudo apt-get autoclean => nothing $ sudo apt-get update $ sudo apt-get upgrade $ sudo rm -r /var/lib/apt/lists/* -vf $ sudo apt-get --fix-broken install

I've tried everything.

How I resolve this?

share|improve this question
    
possible duplicate askubuntu.com/questions/162075/… –  damien Oct 8 '13 at 14:51
    
No, my problem is with broken packages... –  Luiz Carvalho Oct 8 '13 at 14:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.