Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 Amd64 on my laptop but when I use some applications I get ugly looking menus and buttons, Windows 95 like. If I try to change the theme from the appearance settings it doesn't work. Here are some pictures of what I'm talking about

enter image description here

enter image description here

enter image description here

enter image description here

I tried a few things I saw online but they haven't done the trick. I'm kind of wondering how I can get a more modern menu and toolbar, the more default ubuntu looking one.

EDIT

Ran "gnome-settings-daemon" and got errors. Here is what it said.

=== xinerama setup Configuration ===


Clone: false
  Output: Laptop attached to LVDS-0
     status: on
     width: 1366
     height: 768
     rate: 60
     primary: true
     position: 0 0
  Output: (null) attached to VGA-0
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
  Output: (null) attached to HDMI-0
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
  Output: (null) attached to DisplayPort-0
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
=== Applying Configuration Configuration ===
  Clone: false
  Output: Laptop attached to LVDS-0
     status: on
     width: 1366
     height: 768
     rate: 60
     primary: true
     position: 0 0
  Output: (null) attached to VGA-0
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
  Output: (null) attached to HDMI-0
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
  Output: (null) attached to DisplayPort-0
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1

(gnome-settings-daemon:3649): Gdk-WARNING **: The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 263 error_code 8 request_code 140 minor_code 30)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
share|improve this question
    
have you tweaked around with the settings? i.e. did you change anything in the default settings or is this how it's been since the time you installed 12.04? –  Projjol Oct 8 '13 at 5:14
    
That's how it was when I first installed it. –  michaelnana Oct 8 '13 at 5:15
    
"I tried a few things I saw online but they haven't done the trick." Like what? Maybe they made things worse? Could you create a new user account and see how things look there? –  user25656 Oct 8 '13 at 5:38
    
I created a new user account and it still looked the same. I tried things like editing the gnome-settings dameon.desktop file, stop nautrilius, changing themes etc. –  michaelnana Oct 8 '13 at 5:42
    
Do you have a folder called .themes in your home folder? Use ls -a from the command line or first press Ctrl+H if you're using the file manager. If you have such a folder, is it empty? –  user25656 Oct 8 '13 at 5:44

4 Answers 4

As my reputation is too low to add a comment I'll add it here instead. Have you installed the applications through wine, and not the native ubuntu applications? For example with the .exe files instead of through the package manager or with a deb-file?

share|improve this answer
    
Nope not at all. Most of the applications I downloaded were through Ubuntu Software center –  michaelnana Oct 8 '13 at 5:25
    
The other installs I made were .deb files no .exe files –  michaelnana Oct 8 '13 at 5:26
    
So have you or have you not installed software from outside the Ubuntu Software Center? –  user25656 Oct 8 '13 at 5:33
    
What have you installed? Too much to give a list? –  spydon Oct 8 '13 at 5:36
1  
I installed everything from from ubuntu software centre except chrome that I installed using sudo dpkg whcih was a .deb file. There was nothing I installed using wine or that was a .exe file. –  michaelnana Oct 8 '13 at 5:39

This is the default GTK+ theme, and you're probably seeing it because gnome-settings-daemon is not running. You could try just running it from a terminal and see if it gives an error.

Why this would be happening in a fresh install, I don't know, but the errors may give you a clue.

share|improve this answer
    
Isn't what OP's seeing the "fallback" (Raleigh) rather than the default which I think is Ambiance? –  user25656 Oct 8 '13 at 5:32
    
Cool cool I ran gnome-settings-daemon and I got some errors. Check the edit to see them. –  michaelnana Oct 8 '13 at 5:34

Try to switching your theme to default one Ambiance from Appearance.

Goto System Settings -> Appearance -> Look (Tab) -> Theme (Section)

and select Ambiance (default) from drop down.

share|improve this answer
    
Doesn't work. My current theme in appearance is Ambiance. –  michaelnana Oct 8 '13 at 5:49
    
Just a try: Create a new user and switch to newly created user. And see what theme does apply? –  vinaykrsharma Oct 8 '13 at 5:54

I had a very similar problem. Install gtk-theme-switch:

sudo apt-get install gtk-theme-switch

Run it:

gtk-theme-switch

And choose e.g. Ambiance.

I've gone through many topics, finally this is what worked for me, hope it does for you too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.