Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I plug in my USB printer for VMware Workstation 9 to use (Windows 7 guest OS), Ubuntu 13.04 (the host) launches usblp and grabs the printer. VMware then throws up a dialog:

The specified device is claimed by another driver (usblp) on the host operating system.

As a result, I can't use the printer in VMware. I'd like to stop Ubuntu's usblp from doing this. (I never want the printer used on the Linux host, just in the Windows guest.)

Googling this question produces only answers that are 5+ years old and don't work, like running modprobe -r usblp, which doesn't stop usblp from being invoked, or editing /etc/hotplug/blacklist, when /etc/hotplug doesn't seem to exist for Ubuntu 13.04.

The guest OS does have focus when I connect the printer, so that's not the problem. I also looked in VMware Workstation's "VM / Removable Devices" menu but didn't see anything obvious to affect the problem.

Does anyone have a modern way to suppress or disable usblp that works for Ubuntu 13.04?

Thank you very much.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If you want to blacklist usblp you could put it in /etc/modprobe.d/blacklist.conf, or add your own .conf file to /etc/modprobe.d

Overall blacklisting isn't a very satisfying even if it works for you.

share|improve this answer
    
Blacklisting made the dialog go away. However, all that happened is the printer shows up in "Devices and Printers" under the "Unknown" heading. Windows Update is supposed to install the driver automatically. So I found this documentation on making Windows install drivers, rebooted the Windows VM, and plugged in the printer. This time the printer appeared under "Printers and Faxes" (yay!) and I could install the driver using right-click + "Troubleshooting." I'll follow up later if all goes well. –  DanB Oct 8 '13 at 21:57
    
All is well. The driver installed and I can print. It turns out that blacklisting isn't necessary: if usblp launches, simply clicking "OK" on the dialog lets the VM see the printer. The real problem was that my Windows VM was configured not to download drivers. –  DanB Oct 8 '13 at 22:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.