Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.10. I tried to upgrade it using the Software Updater, but it is not working even after pressing Upgrade button. Then I tried to upgrade through the terminal using the command sudo apt-get upgrade. I got the following error message:

sudo: unable to change to sudoers gid: Operation not permitted.  

Please help.

share|improve this question
1  
try sudo do-release-upgrade -d in the terminal. –  Jonathan Rogiest Oct 8 '13 at 2:09
    
Thanks for your cooperation. Surprisingly when I opened the computer yesterday night, it is found that everything was fine and upgrading to 13.04 was also done without any hindrance. I think there was internal problem in 12.04 itself. –  ANUPAM MITRA Oct 9 '13 at 7:20
    
@JonathanRogiest Thank U for above comment, It helped Me! –  Gaurav Oct 21 '13 at 12:54
add comment

1 Answer 1

You may have to upgrade through downloading the ISO for 13.04 and burning it to a DVD. I had a similar problem long ago and that was the only solution.

It shouldn't delete your personal data, but always backup!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.