Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It constantly disconnects and the signal strength goes up and down. The problem is worse when another person connects and download movies. That should be a problem with either my pc or my router because my download speed should keep up with that, but I certainly need help. Thanks in advance.

P.D. I am a noob in Linux, beware.

Output of sudo lspci:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter

Here is the error when "make":

make -C /lib/modules/3.8.0-31-generic/build M=/home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012 modules make[1]: Entering directory /usr/src/linux-headers-3.8.0-31-generic' CC [M] /home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.o /home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.c: In function ‘rtl_action_proc’: /home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.c:872:25: error: ‘RX_FLAG_MACTIME_MPDU’ undeclared (first use in this function) /home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.c:872:25: note: each undeclared identifier is reported only once for each function it appears in /home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.c: In function ‘rtl_send_smps_action’: /home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.c:1434:16: error: ‘struct <anonymous>’ has no member named ‘sta’ make[2]: *** [/home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.o] Error 1 make[1]: *** [_module_/home/alejandro/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012] Error 2 make[1]: Leaving directory/usr/src/linux-headers-3.8.0-31-generic' make: * [all] Error 2

share|improve this question
    
Have you seen this thread yet? Click on the " Dropbox" link askubuntu.com/questions/139632/… –  Mike Oct 7 '13 at 22:37
    
Yep, but do is my problem the rtl8723aeBT drivers? Is not BT same as bluetooth? –  Alejandro_JD Oct 7 '13 at 23:02
add comment

1 Answer

I'm sorry, I'm having a hard time helping you , because I don't have enough rep to leave comments. Yes, BT is bluetooth, but there are further instructions and links on that thread. I hoped your answer would be on there. Looks like alot of people have same issue.

share|improve this answer
    
I appreciate the help, I will try to build the driver listed there. –  Alejandro_JD Oct 7 '13 at 23:22
    
Why am I getting the 2 errors every time I "make"? –  Alejandro_JD Oct 7 '13 at 23:25
    
Post the errors and we'll try to suggest a fix. –  chili555 Oct 8 '13 at 12:37
    
Done pal, posted errors. –  Alejandro_JD Oct 8 '13 at 20:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.