Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
root@ip-10-194-97-94:~# apt-get install uwsgi

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
  uwsgi: Depends: uwsgi-python2.6 (>= 0.9.6.5-0ubuntu1~lucid1) or
                  uwsgi-python3.1 (>= 0.9.6.5-0ubuntu1~lucid1)
E: Broken packages
share|improve this question
1  
what repository does uwsgi belong to? –  steabert Apr 16 '11 at 18:42
add comment

3 Answers

uwsgi is not in the default repositories. You need to add a PPA (Personal Package Archive) and update your sources:

sudo add-apt-repository ppa:uwsgi/release
sudo apt-get update
sudo apt-get install uwsgi
share|improve this answer
add comment

uWSGI is not well packaged. You must either install uwsgi-python or uwsgi-python3. All of the other packages are marked as Conflicts, which is completely confusing and assuredly wrong.

share|improve this answer
add comment

Original text: A melhor forma seria

Translated using Google Translate: The best way would be

sudo add-apt-repository ppa:uwsgi/release
sudo apt-get update
sudo apt-get install uwsgi-python
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.