Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having trouble changing the brightness settings for the backlight on my lenovo y500 with a gt650m gpu.

So I followed this guide here,

http://ubuntuforums.org/showthread.php?t=2095063&page=3&p=12434372#post12434372

I followed the instructions to the T. I can only change my brightness to a medium level and then it locks there. I'm totally new to ubuntu. I have tried all the fixes I've found on google to avail. Please somebody help me. I was happy to at least get it down from an eye blinding level but I still want more control. Thanks for the input.

share|improve this question

2 Answers 2

you can check this folder: /sys/class/backlight/[brightness vendor]/" and changing the numeral value of the file named backlight to 0 (or your desired backlight level). You can set this as a custom shortcut. (I added a chmod to my local.rc file to grand my system access to changing the value of that file). you can also make a shortcut for adding/substracting 50 or 100 to the brightness setting. Just keep in mind that your shortcut command should be formulated like this

bash -c "echo [desired numeral value] > /sys/class/backlight/[backlight vendor]/brightness"

If that doesn't work my backlight problems usually get fixxed by changing this line in your grub (/etc/default/grub)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
share|improve this answer
    
I have already tried your second option with no luck. Can you explain in detail how I make a shortcut like this? I am entirely new to Ubuntu so I don't know a lot of commands. My backlight file is in /sys/class/virtual/backlight/nvidia_backlight/actual_brightness. When I try to edit it, it says I do not have the proper permissions. –  Mack Oct 8 '13 at 16:28
    
did you update your grub (sudo grub-update)?? anyway, to get premissions you'll need to use the command chmod like this: sudo chmod 666 /sys/class/virtual/backlight/nvidia_backlight/brightness –  Arno van der Weijden Oct 8 '13 at 22:37

To resolve the brightness problem on a Lenovo Y500 you should to do the following:

1. In the file "/etc/default/grub" you need to change following string:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

2. Reboot your laptop!

3. Now you can change the brightness of display with following command (for example we want to set 30% of brightness):

echo 30 > /sys/class/backlight/nv_backlight/brightness

4. If you want configure the brightness automatically during booting OS you need the following. After selecting a suitable brightness, add the following command to /etc/rc.local (for example if you have chose 30% of brightness):

echo 30 > /sys/class/backlight/nv_backlight/brightness

I have tested this on my Lapton Y500, GeForce GT 750M (Ubuntu 14.04)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.