Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed a fresh 13.04 Ubuntu 64-bits version on my DELL Latitude laptop and the OS built-in display manager was handling fine the dual monitor mode.

As I wished to have Nvidia driver to have a better experience I followed these steps to get it: http://www.dedoimedo.com/computers/ubuntu-ringtail-nvidia.html

However, after installing NVidia proprietary drivers, my Ubuntu was failing to start properly, and after system start-up, only the desktop was appearing, with no Unity, nor Launcher nor Dash appearing.

Then I could succesfully remove NVidia drivers by doing the following steps:

  1. Switch to console mode: Alt+Ctrl+F1
  2. sudo service lightdm stop
  3. sudo apt-get remove --purge
  4. sudo X -configure
  5. sudo mv xorg.conf.new /etc/X11/xorg.conf
  6. sudo start lightdm

After all this, system was working again, but with this annoying issue: when I try to maximize any window, it always goes maximized to the display on the right.

Also the mouse cursor vanishes on the screen if I drag it to the right edge of the right monitor, and reappears only when I move the cursor back to the left screen.

I have already extensively googled for similar issues reported by other users, and tried some solutions, but the issue still happens for me.

Didn't work for me:

  • using launchpad with Ctrl + SUPER + arrow keys
  • installing COMPIZ config settings manager
  • setting external monitor as primary instead of secondary
  • "dconf reset -f /org/compiz/" followed by "unity --reset-icons &disown"

Any help would be MUCH appreciated, as for now the only solution for this would be reinstalling the whole OS : '(

> Additional info:

This is the following info about my Video card:

~$: lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [NVS 4200M] (rev a1)

Regards, Alysson

share|improve this question
    
Do you have a nvidia card with optimus??? They give a lot of trouble but try bumblebee (if you have a optimus card). It's not perfect but it fixes a lot of problems (dual screen options do not yet work perfectly but with a bit of work you can make it work) –  Arno van der Weijden Oct 8 '13 at 1:53
    
Hi, I have a NVIDIA card with optimus, and I've just updated the question with this info..I'm still new with Linux, so I don't know about bumblebee. I will google it here and give it a try. Thanks :) –  aferreira Oct 8 '13 at 14:58
    
Just an update, I've just installed bumblebee but the issue is still the same thing :'( Followed this tutorial here: howtogeek.com/124685/how-to-make-nvidias-optimus-work-on-linux –  aferreira Oct 8 '13 at 17:09

1 Answer 1

up vote 0 down vote accepted

After you've installed bumblebee what did you do to enable the dual monitor options??

bumblebee has some issues with dual monitor computers. here's a way to make it work correctly (please keep in mind that some hardware may be unfit for this and will not work (properly)).

https://github.com/Bumblebee-Project/Bumblebee/wiki/Multi-monitor-setup

share|improve this answer
    
Much thanks Arno. So yesterday after installing bumblebee, I went to compiz config manager and changed again lot of settings related to screen behaviour, as I did before. It still didn't fix the issue, then today after login into my laptop, it worked fine! Didn't need to follow these latest instructions, but I believe bumblebee+compiz was the solution for this issue. Much thanks!! –  aferreira Oct 9 '13 at 15:20
    
Yeah, it needs a reboot. The tutorial makers thought it was kinda obvious but for new users it really isn't. I should have mentioned it, knowing you're new at this, sorry. –  Arno van der Weijden Oct 10 '13 at 0:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.