Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install libsd1.2-dev, but got an error due to some dependencies that I do not know how to solve.

sudo apt-get -f install libsdl1.2-dev 

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libsdl1.2-dev : Depends: libglu1-mesa-dev but it is not going to be installed or
                      libglu-dev
E: Unable to correct problems, you have held broken packages.

My uname -a is:

Linux moon 3.8.0-31-generic #46-Ubuntu SMP Tue Sep 10 19:56:49 UTC 2013 i686 i686 i686 GNU/Linux

Running Lubuntu-Desktop. Installed is libsdl1.2-debian (version 1.2.15-5ubuntu1)

Any help would be very much appreciated.

share|improve this question

1 Answer 1

if you don't have it already install synaptic package manager. Now under edit click fix broken packages and follow the instructions (I am not sure what they are since I don't have broken packages). Afterward you should probably hit apply and you should be OK.

share|improve this answer
    
Of course, I had tried this. When I select libsdl1.2-dev to be installed I get the red exclamation mark and when I try to install it, Synaptics says that I have to fix the broken package first. If I then choose "fix broken package" I get: E: Unable to correct problems, you have held broken packages. E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies –  Heinz Hopf Oct 7 '13 at 15:51
    
Sorry, I solved the problem. I had unselected the "source" option in the repository settings ... silly me. Thanks Wouter !! –  Heinz Hopf Oct 7 '13 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.