Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have made a Guest user account, where Google Chrome launches at startup. But users are still able to browse all applications from the Unity Launcher.

How can I restrict access to all programs. I want to do this in Unity only (to prove to myself if this is even possible), and only let users see Chrome and LibreOffice.

Currently, they can see all programs and even system settings from the top-right power button.

share|improve this question
Power users will likely still be able to find ways around this lockdown. – Jeremy Bicha Apr 17 '11 at 5:48
up vote 1 down vote accepted

Part One

I think you can solve this doing:

1) Install Compiz Settings Manager from the software center or by clicking here

2) Launch it from System -> Preferences

3) Uncheck Unity like in this picture:

enter image description here

4) Logout and log back in.

Part Two
Others questions

1) To disable Alt + F2:

gconftool-2 --type=string --set /apps/metacity/global_keybindings/panel_run_dialog ''  

2) To disable the shortcut to open the terminal:

gconftool-2 --type=string --set /apps/metacity/global_keybindings/run_command_terminal ''  

3) To add shortcuts to the desktop:

  • Right click on Desktop > Create Launcher


share|improve this answer
Thanks, I will give this a try. I guess I can place just the Chrome and LibreOffice shortcuts on the desktop. Hopefully my guests won't know how to use Alt + F2 or the terminal! However, this raises another question. Is there any easy way in Unity to add shortcuts to the desktop? In Gnome you can right click a menu item and add to desktop. Can't seem to find an alternative in Unity? – nLinked Apr 17 '11 at 11:47
Please ask that as a seperate question to benefit the entire community.. – nik90 Apr 17 '11 at 12:20
Thanks, asked:… – nLinked Apr 18 '11 at 15:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.