Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed and updated Ubuntu but I cant seem to install software. I tried the terminal and it says :

ugwyn@ugwyn-VGN-TX57GN-B:~$ sudo apt-get install flashplugin-installer
[sudo] password for ugwyn: 
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
ugwyn@ugwyn-VGN-TX57GN-B:~$ 

Am I doing something wrong?

share|improve this question
    
answer is in your error it self.. It is clear that you've opened some other process which is taking the lock, like Synaptic or Update Manager or Ubuntu Software Center or something else. Please be sure that you're not using any of this. Close your terminal, open it and try again or Restart your system, I'm sure your problem will be solved.. –  Saur.K Oct 7 '13 at 10:04
    
Rebooting the system will solve the issue –  Joren Oct 7 '13 at 14:16
add comment

2 Answers

This:

E: Could not get lock /var/lib/dpkg/lock - open

Tells us that the something like apt-get is being used/is busy.

This may be caused by update-manager is installing updates when you tried to install the flashplugin-installer, or that there is other software installing and using apt-get.

Multiple actions with apt-get can't be done simultaneously, because it will require the actions to use the same path, so you must wait for the other actions to finish before installing. If this problem occurs for a long time, try to reboot your computer, that may help.

If not, you should edit your question, and add that you have done this, and i will help you out to clean up, in order to make it work again.

share|improve this answer
add comment

The error messages suggest, that some other program is using dpkg. Is there another installation or update in progress? If so, just wait until it finishes, and try again.

Also, software like aptitude or package managers also lock dpkg, closing them will solve the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.